1. Welcome to TalkBass, the Premier Bass Player Community and Information Source. Register a 100% Free Account to post and unlock tons of features.

Ahdown crap or wot!!!!

Discussion in 'Amps [BG]' started by col2558, Feb 12, 2013.

  1. col2558

    col2558

    Feb 12, 2013
    Does anybody have problems with Ashdown amps? I have been using 2 Electric Blue 180¡s and both have the same problem, they keep cutting out or partially cutting out and crackling, The controls have been cleaned so that isn’t the problem! I have just got hold of a MAG evo 2 500 and it has less power than the EB180 and the VU meter is constantly in the red, unlike the EB which is always with loads of headroom. Is it me or are Ashdowns crap???
     
  2. fenderhutz

    fenderhutz Supporting Member

    Jan 28, 2007
    Harpers Ferry WV
  3. gavinspoon

    gavinspoon

    Feb 11, 2008
    Cardiff UK
    I don't know that model, but my Ashdown had issues with the power amp input (the "return" on the send and return sockets on the back). Try putting a patch lead from the send to the return sockets on the FX loop.
     
  4. Bisounourse

    Bisounourse

    Jun 21, 2012
    Gent, Belgium

    +1
     
  5. fenderhutz

    fenderhutz Supporting Member

    Jan 28, 2007
    Harpers Ferry WV
    To clarify why it's you, you are killing the input with too much gain from what it sounds like.
     
  6. jcpassport1

    jcpassport1

    Nov 27, 2002
    New Jersey
    my England made Ashdown abm500 has been solid as a rock for 10 yrs.
     



Share This Page