Alembic Essence Tone Problem

Discussion in 'Pickups & Electronics [BG]' started by etoncrow, Dec 6, 2012.


  1. etoncrow

    etoncrow (aka Greg Harman, the curmudgeon with a conundrum) Gold Supporting Member

    Joined:
    Jun 8, 2007
    Messages:
    2,891
    Location:
    St. Albans, West Virginia
    I had an Alembic Epic 5 as my primary back in the ninties so I know how the Alembic is supposed to sound. I just purchased a 1993 Alembic Essence fretless here on TB. Sounded a bit strange out of the case. I installed new TI Jazz 344 flats; when I went to change out the battery a post terminal broke off with the old battery. Disconnected the battery terminal jack, soldered in a new battery connector and reinstalled with new Duracel 9V. Something is not right. Even at what should be the deepest sounding setting it sounds very trebly and "clanky". Sent an email to Alembic Tech Support yesterday but have yet to receive a reply. Any suggestions or constructive thoughts on a direction are appreciated.
     
  2. etoncrow

    etoncrow (aka Greg Harman, the curmudgeon with a conundrum) Gold Supporting Member

    Joined:
    Jun 8, 2007
    Messages:
    2,891
    Location:
    St. Albans, West Virginia
  3. Vakmere

    Vakmere

    Joined:
    Sep 6, 2007
    Messages:
    2,157
    Location:
    Philly
    Send it to Alembic and have them repair it, or thay can recommend a tech in your area. Call them, emails are too slow.
     
  4. etoncrow

    etoncrow (aka Greg Harman, the curmudgeon with a conundrum) Gold Supporting Member

    Joined:
    Jun 8, 2007
    Messages:
    2,891
    Location:
    St. Albans, West Virginia
    Thanks, I'll call tomorrow.
     
  5. Register to disable this ad

Share This Page