1. Welcome to TalkBass, the Premier Bass Player Community and Information Source. Register a FREE Account to post and unlock tons of features!

Ampeg 4x10 broken tweeter?

Discussion in 'Amps [BG]' started by Spiffmeister, Feb 20, 2014.


  1. Spiffmeister

    Spiffmeister Meister of the Spiffs

    Apr 26, 2012
    Belgium
    Howdy!

    I just plugged in my Ampeg 4x10 today, and I think the tweeter might be broken... The sound is just very dark, and EQ-ing doesn't really brighten it much. On top of that, I get a very noticable buzz when playing certain high notes, like the high A and high E. Other high notes don't have that buzz, or not that much, however...

    Is this a broken tweeter? Or do I remember the Ampeg sound just being much brighter and is this just some frequencies resonating a bit?

    There's still some months of warrantee left on the cab, so I can always bring it in, but I'd chck with you guys first, in case I'm missing something :)
     
  2. Could be, but the good news is replacing it isn't that expensive. You might even want to upgrade it if your going to change it anyways
     
  3. TalkBass Friendly Advertisement

  4. Spiffmeister

    Spiffmeister Meister of the Spiffs

    Apr 26, 2012
    Belgium
    Yeah exactly, and it's still on warrantee :) However, I'm not sure I still want a tweeter, I'm curious how it'll sound without it. Or will it be the same like it does now, but without the buzzing?

    What upgrades are you thinking about?
     



Share This Page