Ampeg BA-115 Buzzing constantly?

Discussion in 'Amps [BG]' started by Kevindavid3, Jan 26, 2014.


  1. Kevindavid3

    Kevindavid3

    Joined:
    Jul 11, 2010
    Messages:
    68
    So long story.

    I have an ampeg ba-115 combo. Never liked the thing just constant problems. I have had owned 3 different basses and all played through that amp. With all those basses the battery running the electronics would only last a month or two and start buzzing so I usually just put it over to passive plug in so it would stop cause I didn't want to go buy batteries every month. And yes I do unplug my basses when im done with them. So anyways, my most resent purchase as a fender american jazz bass with EMG active pickups and pre amp. I bought this bass from by best friend and we jammed a bunch with it through a markbass stack and a old ampeg stack and never had a problem. I bring it home plug it into my ampeg after a day I get buzzing in both passive and active ports. Strangely it stopped after that for a while but would buzz randomly at times. Today thought 1 month after I bought it and a brand new battery the bass is distorting in the active port but not the passive. So the battery is dying. So after that long winded speech my question is, is my ampeg just dying and junk? Also It did have smoke come out of it years ago.

    Sorry for the long speech but I really want this to be answered properly. Every time I think its a problem with my bass I think its a problem with my amp.

    I am planning on upgrading with spring since I have never liked the tone and the buzzing but I would like to maybe fix the problem in the mean time.

    Thanks alot! :D
     
  2. Kevindavid3

    Kevindavid3

    Joined:
    Jul 11, 2010
    Messages:
    68
    Also I used to own a Markbass CMD-102P and never had buzzing, but I had to sell it since I was moving.
     
  3. Kevindavid3

    Kevindavid3

    Joined:
    Jul 11, 2010
    Messages:
    68
  4. JimmyM

    JimmyM Supporting Member

    Joined:
    Apr 11, 2005
    Messages:
    79,961
    Location:
    Apopka, FL
    Disclosures:
    Endorsing: Ampeg Amps, EMG Pickups
    If batteries are only lasting a month or so, it sounds like they're always on and there's something wrong with the wiring or the preamp. I think you need a local expert opinion on your basses and amp all.
     
  5. Register to disable this ad
  6. Phenomoron

    Phenomoron

    Joined:
    Dec 29, 2013
    Messages:
    22
    Having similar issues,bought a new one and put treble past noon she hisses.
    Going ordering a mb 150 Marshall tomorrow!
    I have no confidence in the amp,I'm so disàppointed.
     
  7. JimmyM

    JimmyM Supporting Member

    Joined:
    Apr 11, 2005
    Messages:
    79,961
    Location:
    Apopka, FL
    Disclosures:
    Endorsing: Ampeg Amps, EMG Pickups
    Putting treble past noon makes it awfully bright, though. Any time you turn up the treble it's going to turn up the noise floor of the highs as well, and it'll do it in any amp. Same with any other frequencies.
     

Share This Page