Ampeg SVTIIp schematic?

Discussion in 'Amps [BG]' started by tabooze24, Apr 10, 2014.


  1. tabooze24

    tabooze24

    Joined:
    Apr 22, 2009
    Location:
    Toronto, Ontario, Canada
    Any one have one?

    I need to repair the midrange inductor and need to know the orientation of pins 1 to 4.

    Thanks!
     
  2. Passinwind

    Passinwind Charlie Escher Supporting Member

    Joined:
    Dec 3, 2003
    Media:
    17
    Albums:
    1
    Location:
    Columbia River Gorge, WA.
    Pin 4 to mid pot wiper
    Pin 1 to 470K resistor and pin 2 of mid freq switch

    Not sure where I found it online (via Google, probably) but I did at some point fairly recently. PM me if you can't do likewise and I'll work out a way to get it to you.;)
     
  3. tabooze24

    tabooze24

    Joined:
    Apr 22, 2009
    Location:
    Toronto, Ontario, Canada
  4. tabooze24

    tabooze24

    Joined:
    Apr 22, 2009
    Location:
    Toronto, Ontario, Canada
    Actually, pin 1 goes to a 220K resistor and a capacitor. The capacitor is in series before pin 2 of the mid switch. Pin 1 is marked with a "dot" on the PCB of the SVT IIp.

    I have a schematic of an SVT II NP bass head. The layout of the preamp in the SVT II head and the layout of the SVT IIp are totally different. Infact, the graphic eq frequency centers are also different.
     
  5. Register to disable this ad
  6. Passinwind

    Passinwind Charlie Escher Supporting Member

    Joined:
    Dec 3, 2003
    Media:
    17
    Albums:
    1
    Location:
    Columbia River Gorge, WA.
    Here's a screen shot from my schematic for the II Pro, Rev3:

    [​IMG]
     
  7. tabooze24

    tabooze24

    Joined:
    Apr 22, 2009
    Location:
    Toronto, Ontario, Canada
    The SVT IIp is totally different than the SVT 2 pro.
     
  8. Passinwind

    Passinwind Charlie Escher Supporting Member

    Joined:
    Dec 3, 2003
    Media:
    17
    Albums:
    1
    Location:
    Columbia River Gorge, WA.
    I guess you're talking about the rack mount preamp, right? My bad, never seen nor heard of that model, and assumed you were talking about the II Pro head.
     
  9. Flatbass

    Flatbass

    Joined:
    Mar 13, 2004
    Location:
    Yurop
    Here's the schematic for the SVT-IIP, the single rackspace preamp: http://fileshare.eshop.bg/downloadsm/41186/Ampeg_SVT-2P.html


    By any chance, could you maybe say what could be the culprit when the bright input often drops in volume, but the normal input works perfectly fine?
    It doesn't seem to be a corroded input jack, but what else could it be? Any leads that I could pass on to a tech?
     
  10. B-string

    B-string Gold Supporting Member

    Joined:
    Nov 21, 2008
    Location:
    Lake Havasu City, Az USA
    Intermittent ground on the bright jack most likely, faulty R1 or C1 least likely.
     
  11. tabooze24

    tabooze24

    Joined:
    Apr 22, 2009
    Location:
    Toronto, Ontario, Canada
    Yes. The rackmount pre.
     
  12. tabooze24

    tabooze24

    Joined:
    Apr 22, 2009
    Location:
    Toronto, Ontario, Canada
    Thanks for the link. The quality is really bad :(
     
  13. Flatbass

    Flatbass

    Joined:
    Mar 13, 2004
    Location:
    Yurop
    You haven't clicked on the preview, have you?

    The actual file can be downloaded by clicking on this part:
    "Download >> To download the file, please, click here ! << Download"


    Okay, it's not the most beautiful schematic I've ever seen, but all the info you need should be there.
     
  14. tabooze24

    tabooze24

    Joined:
    Apr 22, 2009
    Location:
    Toronto, Ontario, Canada
    Nope, I downloaded it. Its pretty hard to makeout whats going on unless you zoom on everything!
     

Share This Page