Behringer 4500H noise problem

Discussion in 'Amps [BG]' started by devnullzzz, Mar 14, 2014.


  1. devnullzzz

    devnullzzz

    Joined:
    Mar 14, 2014
    I recently got one of these, but it seems to have a noise issue. Every few seconds or so it booms loudly, like an extremely loud metronome. I have tried adjusting levels, changing cables, etc. but with no change in the behavior.

    Any suggestions or ideas would be greatly appreciated.

    Dave
  2. BassmanPaul

    BassmanPaul Gold Supporting Member

    Joined:
    Aug 25, 2007
    Location:
    Toronto Ontario Canada
    If it is new, take it back and exchange it. If it's used take it to a tech and have the filter caps looked at.
  3. devnullzzz

    devnullzzz

    Joined:
    Mar 14, 2014
    Thanks for your reply. It is used. Any idea how much the cost is to replace the caps? Thanks!
  4. seamonkey

    seamonkey

    Joined:
    Aug 6, 2004
    I would suggest you contact Behringer support, even if it is used. If it's a common problem they might be able to tell you.

    Walking into a tech and saying you think it needs new caps, is bound to cost the cost of new caps. :bag:
  5. Register to disable this ad
  6. Sean Fairchild

    Sean Fairchild

    Joined:
    Nov 15, 2013
    Disclosures:
    Specialist, Product Support: BEHRINGER
    Dear devnullzzz,

    I would suggest getting in touch with our Care department - they can advise on servicing, troubleshooting the issue, etc. Just send them an email at care@music-group.com. Thanks, and good luck!

    Best regards,
    Sean Fairchild
    Specialist, Channel Marketing Prosumer Division
    MUSIC Group
    BEHRINGER

Share This Page