1. Welcome to TalkBass 2014! If you're new here, we just went through a major site upgrade. Please post all concerns and bugs to the Forum Usage Issues forum. We will be monitoring that forum. Thank you for all of your feedback.

    The TB Android app is working, you may need to uninstall/reinstall. The iPhone app is now updated and should work after you upgrade. TalkBass is responsive to any screen size, so we recommend using your mobile browser for full functionality.

    Please read the TalkBass 2014 FAQ for lots of great info on the new software.

broken eden nemesis na 320 head, How can I fix this?

Discussion in 'Amps [BG]' started by Karlou Sinatra, Feb 16, 2014.

  1. Karlou Sinatra

    Karlou Sinatra

    Joined:
    Feb 16, 2014
    Likes Received:
    0
    I have an eden nemesis na 320 4 ohm head running into an 8 ohm hartke cab. When I turn on the head the bass is quiet and buzzy and whenever I turn the head off it makes a loud squealing noise. I clearly have little knowledge of how any of this works, so please post if you know anything that could help. Thank you.
  2. wisconsindead

    wisconsindead

    Joined:
    May 16, 2013
    Likes Received:
    0
  3. O-evetS

    O-evetS I like pie! Supporting Member

    Joined:
    Jul 6, 2003
    Likes Received:
    0
    I had one of those a few years ago. It kept blowing filter caps. It sounded just like that. It happened 4 times. I had it fixed and got rid of it. Sounded great when it worked though.
  4. BassmanPaul

    BassmanPaul Gold Supporting Member

    Joined:
    Aug 25, 2007
    Likes Received:
    8
    It's good old Tech Time. Sorry.

Share This Page