1. Welcome to TalkBass 2014! If you're new here, we just went through a major site upgrade. Please post all concerns and bugs to the Forum Usage Issues forum. We will be monitoring that forum. Thank you for all of your feedback.

    The TB Android app is working, you may need to uninstall/reinstall. The iPhone app is now updated and should work after you upgrade. TalkBass is responsive to any screen size, so we recommend using your mobile browser for full functionality.

    Please read the TalkBass 2014 FAQ for lots of great info on the new software.

D-Tar Equinox

Discussion in 'Effects [BG]' started by EdwardofHuncote, Dec 21, 2013.

  1. EdwardofHuncote

    EdwardofHuncote Supporting Member

    Joined:
    Aug 21, 2013
    Likes Received:
    0
    I have a D-Tar Equinox preamp/parametric eq/notch filter that's acting really strange. When the power is connected, the green power-on indicator doesn't come on, but the red input gain clip light stays on. When I disconnect the power, the red clip warning led goes out but the green led glows for just a second.

    And obviously, the preamp isn't working. :(

    Realizing it's a long shot, but this thing is essential for shaping my upright tone for hi-gain situations. Hate to buy another if it can be fixed. Anybody else seen this?
  2. EdwardofHuncote

    EdwardofHuncote Supporting Member

    Joined:
    Aug 21, 2013
    Likes Received:
    0
    *Update*

    An electronic-savvy bud tells me it sounds like the "power rail" is bad.

    I know as much about electronics as he does about playing bass... so, anyone here know if that is a replaceable part?
  3. EdwardofHuncote

    EdwardofHuncote Supporting Member

    Joined:
    Aug 21, 2013
    Likes Received:
    0
    Sending back to D-Tar for repairs... hopefully this will be covered by warranty. Either way, this is a critically important piece of gear for amplifying the upright bass. Gotta have it.

Share This Page