1. Welcome to TalkBass 2014! If you're new here, we just went through a major site upgrade. Please post all concerns and bugs to the Forum Usage Issues forum. We will be monitoring that forum. Thank you for all of your feedback.

    The TalkBass iphone/android app is NOT WORKING currently. We're working on it. Tapatalk IS working, so if you need to use an app, use Tapatalk. Try using your browser though - TalkBass is now 100% responsive to your phone/tablet screen size ;)

    Please read the TalkBass 2014 FAQ for lots of great info on the new software.

Demeter Comp-1 trimpot trouble

Discussion in 'Pickups & Electronics [BG]' started by Ray man, Jan 11, 2014.

  1. Ray man

    Ray man

    Joined:
    Nov 5, 2009
    Likes Received:
    0
    With the pedal turned on, it makes a continuous low level static/crackle even without an instrument pluged in.
    It seems to be coming from the internal trimpot. It gets worse when adjusting it, also tugging or jiggling it.
    I tryed to use cleaner but no good. I'm gonna try and replace it but I need a link for a replacement part.

    Thanks guys
  2. Ray man

    Ray man

    Joined:
    Nov 5, 2009
    Likes Received:
    0
  3. Ray man

    Ray man

    Joined:
    Nov 5, 2009
    Likes Received:
    0
    Wrong forum?
  4. Ray man

    Ray man

    Joined:
    Nov 5, 2009
    Likes Received:
    0
  5. Ray man

    Ray man

    Joined:
    Nov 5, 2009
    Likes Received:
    0
    The number on the trimpot is 103 v.
    Maybe that helps.

Share This Page