Dismiss Notice

Welcome to TalkBass.com!

Register your free account to unlock features including:

  • Post messages or start new discussions
  • Send private messages to other members
  • Upload images and video to our gallery
  • Enter free giveaways
  • Get rid of this notice, and much more :)

Demeter Compulator volume dropping....

Discussion in 'Effects [BG]' started by punchdrunk, Dec 16, 2013.


  1. punchdrunk

    punchdrunk Supporting Member

    Jun 22, 2013
    Jacksonville, Fl
    Hi guys, has any one else had any issues with the compulator dropping out volume wise? it runs beautifully, then it will suddenly lose volume gradually (i have to compensate by rote with the volume boost until it is no longer operative). I have the compression set low at around 8-9 o clockish, and have the issue with both a new battery installed, and with a plug installed. Any one have this problem?
     
  2. rratajski

    rratajski

    Jul 1, 2008
    Mount Laurel, NJ
    Disclosures:
    Builder for FUZZROCIOUS PEDALS
    Never had this issue. What was Demeter's answer?
     
  3. Sounds like you have a problem with the pedal. Maybe email Demeter with a description.
     
  4. punchdrunk

    punchdrunk Supporting Member

    Jun 22, 2013
    Jacksonville, Fl
    Turns out to be a faulty toggle switch. All is well!
     
  5. Sponsored by:

  6. rratajski

    rratajski

    Jul 1, 2008
    Mount Laurel, NJ
    Disclosures:
    Builder for FUZZROCIOUS PEDALS
    You have a toggle on yours?
     
  7. punchdrunk

    punchdrunk Supporting Member

    Jun 22, 2013
    Jacksonville, Fl
    Not a toggle, but the on/off foot switch.
     



Play guitar too? Become a founding member of TalkGuitar.com