1. Welcome to TalkBass, the Premier Bass Player Community and Information Source. Register a FREE Account to post and unlock tons of features!

Dose your GK amp make a little pop noise when you power up and power down?

Discussion in 'Amps [BG]' started by 4stringsrenough, Dec 11, 2012.


  1. 4stringsrenough

    4stringsrenough

    May 8, 2012
    Mine dose just wondered if this us normal?
     
  2. Do you have your gain/volume at zero when you power up/down?
     
  3. Sponsored by:

  4. 4stringsrenough

    4stringsrenough

    May 8, 2012
    Yes I do also use the mute switch as well the pop sound is very minimal
     
  5. 4stringsrenough

    4stringsrenough

    May 8, 2012
    Yes I do, thanks
     
  6. My 1001rb makes a loud pop. My 600 Backline does not. I will try the volume and gain off but hard to see how that will help as volume is set on 1.
     
  7. 4stringsrenough

    4stringsrenough

    May 8, 2012
    Thanks mam, I don't think it's an issue just wonders if anyone else had this mines a rb700 II
     
  8. IPYF

    IPYF

    Mar 31, 2011
    Melbourne, Australia
    I have a 1001 and it pops. Always has.
     
  9. 4stringsrenough

    4stringsrenough

    May 8, 2012
  10. Electricblue

    Electricblue

    Feb 1, 2011
    Norfolk
    Never had a GK, but I can tell you this.

    My Ashdown MAG300 does it, my guitar combo does it, most of my synths do it, my hifi power amp does it, and so do my portable MP3 speakers.

    All pretty standard man :)
     
  11. RenorCordic

    RenorCordic

    Nov 12, 2009
    Pittsburgh
    I have 2 2001rb's. My first one does pop when powered up and my second does not. The first one's clip light also blinks on for a sec when it is first powered up. I've never had the issue looked at.
     
  12. jumbodbassman

    jumbodbassman Supporting Member

    Dec 28, 2009
    Stuck in traffic -NY & CT
    Disclosures:
    Born Again Tubey
    normal for GK. my 800rb did it for 15 years till it died.
     
  13. tdub0199

    tdub0199

    Mar 4, 2010
    Atlanta, Ga.
    This is pretty normal for my 1001RB II....
     
  14. 4stringsrenough

    4stringsrenough

    May 8, 2012
    Ok this is all good stuff , it's nice to know it a common thing
     
  15. BassmanPaul

    BassmanPaul Gold Supporting Member

    Aug 25, 2007
    Toronto Ontario Canada
    All SS amps give some noise as they power up or down. This is perfectly normal. Most amps have a delay on, instant off for the speakers jacks minimizing the noise that gets through. This is the audible click you can hear a few seconds after power on.
     
  16. Yes, and yes it's also normal too.
     



Share This Page