1. Welcome to TalkBass 2014! If you're new here, we just went through a major site upgrade. Please post all concerns and bugs to the Forum Usage Issues forum. We will be monitoring that forum. Thank you for all of your feedback.

    The TB Android app is working, you may need to uninstall/reinstall. The iPhone app is still pending approval by Apple. If you haven't yet, try using your mobile browser - TalkBass is responsive to any screen size.

    Please read the TalkBass 2014 FAQ for lots of great info on the new software.

EBS ValveDrive making noise.

Discussion in 'Effects [BG]' started by OptimusPrime, Dec 23, 2012.

  1. OptimusPrime

    OptimusPrime

    Joined:
    Mar 30, 2008
    Likes Received:
    0
    Just the other day I noticed my EBS ValveDrive making unwanted static noise. It's the worst when you turn the volume knob, and wont go away until you tap the pedal a few times. Bad connection on the pot? I don't beat up the pedal, I'm not a touring musician. Of course it has to be my most expensive one too. Any ideas? It's kinda irritating me.
  2. BawanaRik

    BawanaRik Supporting Member

    Joined:
    Mar 6, 2012
    Likes Received:
    0
    Clean your inputs and check you cables. It might not be the pedal. It might be the cables.
  3. OptimusPrime

    OptimusPrime

    Joined:
    Mar 30, 2008
    Likes Received:
    0
    Ok, finally got around to seeing what I can do with this pedal. Cleaned the inputs with alcohol and tried different cables. No luck. Now I'm getting noise almost the whole time the pedal is on, not just when turning knobs. Try a new tube? Get contact cleaner and clean the pots? I'm lost, and quite angry.
  4. RickenBoogie

    RickenBoogie

    Joined:
    Jul 22, 2007
    Likes Received:
    0
    Swap the tube out AND clean the pots.
  5. OptimusPrime

    OptimusPrime

    Joined:
    Mar 30, 2008
    Likes Received:
    0
    Bought some DeoxIT contact cleaner for the pots. I'll see what that does and order a new tube if necessary... Thanks guys.
  6. OptimusPrime

    OptimusPrime

    Joined:
    Mar 30, 2008
    Likes Received:
    0
    Contact cleaner helped a lot it seems, although I'm still getting the slightest crackle in the travel of the volume pot. I'll give it a second shot tomorrow, gotta head out now.

Share This Page