1. Welcome to TalkBass, the Premier Bass Player Community and Information Source. We've been uniting the Low End Since 1998!

    We're glad you've found us. Register a 100% Free Account to post and unlock tons of features.

Epifani UL410 series 2 crossover or tweeter issue

Discussion in 'Amps [BG]' started by grumpyjfc, Nov 24, 2013.


  1. grumpyjfc

    grumpyjfc Supporting Member

    Joined:
    Sep 25, 2003
    Location:
    Mount Pleasant SC
    My Genz Benz shuttlemax 6 went nuclear one night while hooked into my UL410 and made an increadibly loud squeal when I tried to adjust the mids. GB hase been fixed, but since then the tweeter adjustment on the 410 is unresponsive. I can hear a hiss in the tweeter when the amp is turned on but no sound comes through it when playing. Also noticed some slight distortion on our last gig that the rest of the band said they could hear too. Is my crossover toast? If so, will Epifani sell me a new one?

    I also fear one or more speakers are blown. B&C has a new 300watt version out, will this work in my cab if I replace all four. Believe the cab to be a version 1.

    How do you test a speaker to see if its good. Sound is coming from all four when in my room at lower levels & sounds fine. Dont see any loose insulation.....
     
  2. Virgil

    Virgil She's My Inspiration

    Joined:
    Nov 30, 2005
    Location:
    Dresher, Pa.
    The coil on one of your speakers is toast. The same thing happened to me. It was hard to isolate which speaker coil was shot. We had to check each speaker individually until we found it.
     

Share This Page