Euphonic Audio CXL112

Discussion in 'Amps [BG]' started by thehurlatron, Mar 18, 2006.


  1. thehurlatron

    thehurlatron

    Joined:
    Jan 13, 2004
    Messages:
    2,393
    Location:
    Holland, Michigan
    I just picked one of these off the 'bay for cheap. It's the older version (heavier).

    I hooked this up with my VL-210 and my DB750. With the DB already eq'd for my VL-210, the cxl112 sounds very thin and lacking in the bottom end. Is this the nature of the cxl112, or is something wrong here? When I unplug the cxl, the vl210 still sounds deep and tight.

    Does the CXL112 really require THAT much more eq? If so, it is not paired well with the 210, for the 210 is at it's optimum setting for low end.


    HELP!!!
     
  2. Steve Clark

    Steve Clark Supporting Member

    Joined:
    Jan 9, 2004
    Messages:
    2,477
    Location:
    London ON
    I would suggest contacting John at EA to see what he has to say about the cabinet. While I have only played the lighter version I have plenty of low end running that cabinet on its own let alone with a 210. I ran the cabinet flat last night and had plenty of low end using an iAMP800.
     
  3. bikeplate

    bikeplate Supporting Member

    Joined:
    Jun 7, 2001
    Messages:
    7,632
    Location:
    Upstate NY
    HI

    Yea. My 800 combo has the 12 inch speaker. I also have the nl210. Tone of bottom.

    Rob
     
  4. iammr2

    iammr2

    Joined:
    Jun 10, 2002
    Messages:
    721
    Location:
    Tejas
    Thin??? Hmmm...Hook it up by itself and see if it still sounds thin. Check the tweeter level. If it's phat by itself and thin with the 210, it's a phase problem.
     
  5. Register to disable this ad
  6. Matt Morgan

    Matt Morgan Fellow Conspirator Supporting Member

    Joined:
    Oct 21, 2001
    Messages:
    1,556
    Location:
    En route to Dallas, TX
    My CXL112Ls have TOO much bottom. I'm looking for a cab or cabs that have a little less bottom! These things have a serious attitude in the low end. If you're not getting low end out of them, or not cautiously EQ their low end, there's an issue.
     
  7. wneff

    wneff

    Joined:
    May 27, 2003
    Messages:
    310
    Location:
    Woburn, MA
    Both my CXLs needs either bass boost or mid-cut.

    BUT - my bass is bright and mid-rangy (Bartolini PUs). Most other basses I played have more bottom then mine.

    Wolfram
     
  8. pedroferreira

    pedroferreira

    Joined:
    Feb 10, 2003
    Messages:
    384
    Location:
    Portugal
    I think you hava a phase problem ;)

    Pedro
     
  9. Bass Boy

    Bass Boy

    Joined:
    Jan 28, 2000
    Messages:
    1,934
    Location:
    Montreal, Quebec, Canada
    I agree. I almost always cut the bass on my iAMP when using my cxl12s.
     
  10. thehurlatron

    thehurlatron

    Joined:
    Jan 13, 2004
    Messages:
    2,393
    Location:
    Holland, Michigan
    Well.......

    I hooked up the DB750 to the CXL ALONE, and it still is lacking in the bottom end. When I hit an open E or anything on the B string, it just sounds very weak. It doesn't make any funny noises or popping sounds, just weak, (all treble and high mids)

    With the same settings on the DB750, I switch the CXL for the VL-210, and BOOM! there's the sound I'm talking about!
    Big bottomed low end.

    Should I take this thing apart and inspect the speaker? (like I know what to look at:confused: :) )
     
  11. jokerjkny

    jokerjkny

    Joined:
    Jan 19, 2002
    Messages:
    13,429
    Location:
    NY / NJ / PA
    hmm...

    sounds like the driver has seen better days. i'm sure gary'll give you the hook up.
     
  12. Steve Clark

    Steve Clark Supporting Member

    Joined:
    Jan 9, 2004
    Messages:
    2,477
    Location:
    London ON
    email John at EA. john@euphonicaudio.com It's sounds like something has gone in the speaker. My guess is the tweeter is still working but the woofer is blown.
     
  13. thehurlatron

    thehurlatron

    Joined:
    Jan 13, 2004
    Messages:
    2,393
    Location:
    Holland, Michigan

    I emailed him and got the response of "send the whole cab in, and we'll take a look at it".

    I was hoping for a "try looking at this" or "just send the speaker", or "the replacement speaker will cost...".

    Don't get me wrong, I got a response back in like 15 min, so that is AWSOME, but I was hoping I didn't have to spend $100 both ways in just shipping to have it diagnosed.
     
  14. Reefer

    Reefer Guest

    Joined:
    Mar 9, 2003
    Messages:
    1,079
    If it were me I'd pull the speaker and make sure one of the leads didn't come loose during shipping. I've seen it happen!
     
  15. thehurlatron

    thehurlatron

    Joined:
    Jan 13, 2004
    Messages:
    2,393
    Location:
    Holland, Michigan

    I just got done checking that. Everything seems to be intact.

    I still have the speaker out, and copied down the numbers on the speaker just incase I need them for support to EA.

    The speaker looks good also. no tears or breaks underneath the cone.

    I am a little confused though.

    On one part of the speaker, there is a sticker with a # and such and says 8ohms.
    On another part of the speaker, there is another sticker with a #, and says 4 ohms.
    HMMM.
    Is one for the 12, and one for the horn?
     
  16. Reefer

    Reefer Guest

    Joined:
    Mar 9, 2003
    Messages:
    1,079
    I believe one is the 12 and the other is the horn.

    I may be wrong, but it is my understanding that the drivers for the original CXL112's are no longer available, the CXL112L uses a different driver.
     
  17. Reefer

    Reefer Guest

    Joined:
    Mar 9, 2003
    Messages:
    1,079
    ??? Is your VL210 a 8 or 4 ohm cab?

    I've owned both the VL210 and the CXL112 and the VL210 puts out such serious bass response it's hard to expect similar response from the 112.
     
  18. thehurlatron

    thehurlatron

    Joined:
    Jan 13, 2004
    Messages:
    2,393
    Location:
    Holland, Michigan
    It's 8ohms with the BIG magnets.
    I love this cab, but I'm trying to pair it with something for larger gigs. When played alone on a medium gig with no PA, it gets lost really quick. I played it with my ampeg BXT210M, and together it pumped. SO, I thought with how many good things I've heard about the CXL112, I thought I'd give it a whirl.


    Maybe my ears (and expectations) are crazy. Maybe the cab is fine and I'm just used to super bottom end. Maybe I need to add another VL210 or a NL210. HMMMM
     
  19. Reefer

    Reefer Guest

    Joined:
    Mar 9, 2003
    Messages:
    1,079
    I have 2 of the VL210's with the 105oz mags, AWESOME!!
     
  20. wneff

    wneff

    Joined:
    May 27, 2003
    Messages:
    310
    Location:
    Woburn, MA
    Hi,

    Fed Ex ground for the CXL12 is only $18, I would (and i did in thepast) send the whole box just in case there is somethig else screwy.


    Wolfram
     
  21. thehurlatron

    thehurlatron

    Joined:
    Jan 13, 2004
    Messages:
    2,393
    Location:
    Holland, Michigan

    I smell what you're steppin' in, so I did a quick fedex rate, I know I'm pulling hairs, but I come up with like $26ish each way. I add that to what I just paid, and I begin to cringe.

    As stated in a post earlier, maybe my ears are just funky, or I was expecting something totally different. I'd hate to ship it there and back to find out nothing is wrong. (even though my best guess is that something is)
     

Share This Page