Gallien Krueger problems in Australia

Discussion in 'Amps [BG]' started by jimmeyer176, Nov 21, 2012.


  1. jimmeyer176

    jimmeyer176

    Joined:
    Oct 2, 2012
    Heya

    So I'm on my second MB500 head and once again te clip light is no longer working.

    Now, the shop I got it from in Sydney has gone bust and the distributor of GK down here is notoriously bad. I'm still waiting to hear back from them but last time this happened they had the head for nearly 8 weeks before simply replacing it, so I'm looking for other options.

    Since the head is so light I'm thinking perhaps I could send it direct to GK in the US? I have the original packaging so it would be protected. I'm not very confident in this head anymore, it was used 3 times before breaking, and to make it worse most people wouldn't notice...they would just think the amp wasn't clipping. Very frustrating to say the least! Thoughts?

    Thanks
     
  2. Fuzzbassian

    Fuzzbassian

    Joined:
    Jan 12, 2012
    Does it still work?
    I wouldn't go sending it ll the way to the other side of the world just for a light not working.
    Maybe contact the GK customer service (not the aussie distributor) and ask for advice.They might point you in the direction of a repair shop.Who knows.
    For all the people who got cheap **** from allans/billy hyde closing down,there had to be a downside hey?
     
  3. IPYF

    IPYF

    Joined:
    Mar 31, 2011
    Location:
    Melbourne, Australia
    If you have the resources and can be bothered you can send it to Electric Factory in Melbourne. It might cost you a small fortune in freight but I've had them fix my GK head twice now and while they are very busy they're excellent at what they do.
     

Share This Page