GK Backline 110 problem

Discussion in 'Amps [BG]' started by bassdog, Aug 9, 2013.


  1. bassdog

    bassdog

    Joined:
    May 23, 2005
    Location:
    Atlanta, Ga
    Hi. I could use a bit of advice. I have one of these little amps. A while ago it began to giving a slight popping sound intermittantly. Now it will give a crackle sound intermittantly, like a cable might do. It's not the cable though. Is it worth getting fixed? Any ideas what might be the problem? Thanks for any replies.

    Bob
  2. kilgoja

    kilgoja

    Joined:
    May 26, 2005
    Location:
    Alabama
    does your bass use a 9v battery? it could be the battery is going dead.
  3. grey area

    grey area

    Joined:
    Sep 2, 2009
    Location:
    almeria spain
    hi.i have one of these little amps in india( i leave it there for about 6 months during monsoon)and usualy when i fire her up she makes a whole bunch of noises including pops and squeaks crackles. i take a can of electrical cleaner/ lubricator with me now and a half hour spraying and lubeing brings her back as good as new.you may not have the same humidity problems as i do but if you give her a good clean, including all the jack sockets pots, etc, if it still does it at least youve eliminated oxidation as the cause. i like my little backline as it was my first exposure to the GK sound. its not loud but fits nicely with my small accoustic indian jazz fusion jam band. hope you get it sorted.
    shanti shanti.
  4. bassdog

    bassdog

    Joined:
    May 23, 2005
    Location:
    Atlanta, Ga
    "does your bass use a 9v battery? it could be the battery is going dead."

    No, not active but thanks for the reply. I suspect it may be capaciter related but don't really know. I may just get it looked at and get a repair estimate maybe. Only a $200.00 amp.

    I'll give it a good cleaning too and see what happens. Thanks.



Share This Page