1. Welcome to TalkBass 2014! If you're new here, we just went through a major site upgrade. Please post all concerns and bugs to the Forum Usage Issues forum. We will be monitoring that forum. Thank you for all of your feedback.

    The TB Android app is working, you may need to uninstall/reinstall. The iPhone app is now updated and should work after you upgrade. TalkBass is responsive to any screen size, so we recommend using your mobile browser for full functionality.

    Please read the TalkBass 2014 FAQ for lots of great info on the new software.

GK MB Fusion thru Avatar 212 Neo fizzy sound...

Discussion in 'Amps [BG]' started by MisterFabulous, Dec 11, 2012.

  1. MisterFabulous

    MisterFabulous

    Joined:
    Feb 4, 2010
    Likes Received:
    0
    So I have the MB Fusion going through an Avatar 212 Neo connected by a 14 AWG Speakon-to-Speakon.

    The head and the cab are both used. I am using them for practice with good results.

    I am not playing at high volume or crazy EQ settings.

    But I am noticing this week a fizzy, distorted decay at the end of every note pretty much. Sometimes it is not present, as when the rig is first on.

    Is this the dreaded farting? Am I overpowering the cab? (Both are rated @ 500W @ 4 Ohms).
  2. KJung

    KJung Supporting Member

    Joined:
    Apr 9, 2005
    Likes Received:
    4
    Sounds like a tube issue. It happens sometimes. Might be as simple as reseating the three tubes, might need a new preamp tube.

    I would call GK and have them talk you through checking the tube.

    That being said, voice coil troubles also sound like that (kind of a crinkling sound as the note decays).

    Let's hope it is just a simple tube swap, and you will be good to go most likely.
  3. MisterFabulous

    MisterFabulous

    Joined:
    Feb 4, 2010
    Likes Received:
    0
    Thanks, I'll give a call to GK.
  4. DiabolicLow B

    DiabolicLow B

    Joined:
    Nov 12, 2009
    Likes Received:
    0
    I had a similar issue with my MB Fusion and noticed the middle tube looked out of line with the others. I opened it up and reseated the tubes (which are very hard to get at so be careful!) and all was good. Great amp BTW!

Share This Page