1. Welcome to TalkBass 2014! If you're new here, we just went through a major site upgrade. Please post all concerns and bugs to the Forum Usage Issues forum. We will be monitoring that forum. Thank you for all of your feedback.

    The TalkBass iphone/android app is NOT WORKING currently. We're working on it. Tapatalk IS working, so if you need to use an app, use Tapatalk. Try using your browser though - TalkBass is now 100% responsive to your phone/tablet screen size ;)

    Please read the TalkBass 2014 FAQ for lots of great info on the new software.

GK MB112 Combo: Staticy after warms up

Discussion in 'Amps [BG]' started by Squirefan01, Jan 28, 2014.

  1. Squirefan01

    Squirefan01 Supporting Member

    Joined:
    May 14, 2006
    Likes Received:
    0
    I've had this combo amp for over a year and it's been great. Lately it has developed a high static sound after it warms up for awhile. Like AM radio static. It does not get better or worse when I plugin or play through. I assume it's something in the electronics, and have not found anything described online that sounds like it.

    Has anybody had an issue like this with GK combo cabs? Anything specific to look at first?

    Thanks,
  2. B-string

    B-string Supporting Member

    Joined:
    Nov 21, 2008
    Likes Received:
    2
  3. Squirefan01

    Squirefan01 Supporting Member

    Joined:
    May 14, 2006
    Likes Received:
    0
    Done. Thanks!
  4. B-string

    B-string Supporting Member

    Joined:
    Nov 21, 2008
    Likes Received:
    2
    You're welcome. No need poking around when the warranty will take care of it. :)
  5. Squirefan01

    Squirefan01 Supporting Member

    Joined:
    May 14, 2006
    Likes Received:
    0
    I'm just terrible with paperwork so I probably do not have any proof of purchase.

Share This Page