GK MB210 vs. MB210 II

Discussion in 'Amps [BG]' started by pgolliher, Jan 20, 2014.


  1. pgolliher

    pgolliher

    Joined:
    Apr 27, 2010
    Location:
    Santa Cruz, CA
    Hi- I have an MB210 (early version) which I have loved. Tone, weight, etc. Now, it is having some issues (burning electrical smell when using extension cab- power going on and out, but not shutting down.) I am considering upgrading to the MB210 II but when I read reviews on retailer websites, the reviews of the MB210 II state the exact problem I am having. Does anyone have actual experience with the new model? Any quality issues. (I know the new models are made in the USA- old ones China, etc..looking for real experience- not opinions- thanks!)
     
  2. pgolliher

    pgolliher

    Joined:
    Apr 27, 2010
    Location:
    Santa Cruz, CA
  3. dwjazz54

    dwjazz54

    Joined:
    Jan 21, 2003
    Location:
    Jersey City, NJ
    Can't respond directly to the 210, or even quality control in relation to the older models, but...my MB212-ii, aside from the great tone and portability, has been BULLETPROOF. I can only assume that the quality on the second-gen 210 is equal.

    Of course, with any mass-produced product, there will be lemons. But word is that GK customer service (I've never personally had to use them) is excellent.
     
  4. pgolliher

    pgolliher

    Joined:
    Apr 27, 2010
    Location:
    Santa Cruz, CA
    Thanks for the feedback. Their customer service has been excellent- I am just cautious because of the reviews I read.
     
  5. Register to disable this ad
  6. B-string

    B-string Gold Supporting Member

    Joined:
    Nov 21, 2008
    Location:
    Lake Havasu City, Az USA
    Not related to your issue (which could be a dirty or defective fan causing the volume in and out) low VOC solvents "burning off" on new units can and do smell like something burning. Depending on how hard the unit is run it can take some time to dissipate.
     
  7. pgolliher

    pgolliher

    Joined:
    Apr 27, 2010
    Location:
    Santa Cruz, CA
    Thanks. The fan looks fine, but I haven't plugged it in and played to see if its spinning.
     
  8. pgolliher

    pgolliher

    Joined:
    Apr 27, 2010
    Location:
    Santa Cruz, CA
    Bump for more feedback. Thanks!
     

Share This Page