1. Welcome to TalkBass 2014! If you're new here, we just went through a major site upgrade. Please post all concerns and bugs to the Forum Usage Issues forum. We will be monitoring that forum. Thank you for all of your feedback.

    The TB Android app is working, you may need to uninstall/reinstall. The iPhone app is now updated and should work after you upgrade. TalkBass is responsive to any screen size, so we recommend using your mobile browser for full functionality.

    Please read the TalkBass 2014 FAQ for lots of great info on the new software.

Hartke A70 speaker problem

Discussion in 'Amps [BG]' started by sii.pepenk, Jan 28, 2014.

  1. sii.pepenk

    sii.pepenk

    Joined:
    Jun 3, 2010
    Likes Received:
    0
    i got a Hartke A70 for a few days, but something coming up. there's a 'brrrrrrrr' sound when i play some low note, then i check the speaker on the surface (front cone) and find no cut or broken at all. then i check behind speaker from a hole to make sure that there is no spider web, dust or something else and i found it is pretty clean

    i'm afraid that something going on inside the speaker cone, any suggestion for this?

    for the worst possiblity, if i replace the speaker (for a better one maybe) is it worthed? the speaker spec is 12" with 8ohm, so what kind of speaker will fit for this amp?
  2. JimmyM

    JimmyM Supporting Member

    Joined:
    Apr 11, 2005
    Likes Received:
    85
    Disclosures:
    Endorsing: Ampeg Amps, EMG Pickups
    What's your bass knob set at? How loud? Could be you're just asking more from it than it can give you...?
  3. RickenBoogie

    RickenBoogie

    Joined:
    Jul 22, 2007
    Likes Received:
    0
    +1 pushing the low eq eats your power, and is hard on spkrs. CUT the lows.
  4. sii.pepenk

    sii.pepenk

    Joined:
    Jun 3, 2010
    Likes Received:
    0
    i use all the knob to flat seting, even the volume knob only on 9

Share This Page