1. Welcome to TalkBass, the Premier Bass Player Community and Information Source. We've been uniting the Low End Since 1998!

    We're glad you've found us. Register a 100% Free Account to post and unlock tons of features.

Hartke Hydrive Making an Exploding Noise

Discussion in 'Amps [BG]' started by Steveman, Jan 9, 2014.


  1. Steveman

    Steveman

    Joined:
    Jun 25, 2010
    So I turn on my Hartke Hydrive and it starts making this REALLY LOUD that sounds like an explosion. This problem persists even when the volume is all the way down at 0 and nothing is plugged in, does anybody have any idea what on earth could be happening?
     
  2. B-string

    B-string Gold Supporting Member

    Joined:
    Nov 21, 2008
    Location:
    Lake Havasu City, Az USA
    The more pertinent question is what is wrong with the amp sending that noise to the cab. What amp head are you using?
     
  3. swamp_bass

    swamp_bass I love it when a groove comes together

    Joined:
    Nov 20, 2013
    Location:
    North Cackalacky
    Yeah, I agree. Unless your Hydrive has learned to generate its ow power, the problem is the amp. Unplug it pronto before it does anything bad.

    *** Edit; I just realized you're probably using a combo. Either way, it sounds like the head could be shot.
     
  4. Steveman

    Steveman

    Joined:
    Jun 25, 2010
    It's a Hartke Hydrive 112c combo amp.
     
  5. Register to disable this ad
  6. B-string

    B-string Gold Supporting Member

    Joined:
    Nov 21, 2008
    Location:
    Lake Havasu City, Az USA
    You need to get it serviced. Could be just a bad solder joint, failing component or something arcing inside the amp head.
     

Share This Page