Help! Acoustic B100 issue.

Discussion in 'Amps [BG]' started by 66musicmaster, Dec 20, 2013.


  1. 66musicmaster

    66musicmaster

    Joined:
    Nov 1, 2010
    Hey guys - been a long time since I've been in but all has been good and fun til recently. My son was using our Acoustic B100 for school band and the passive input jack and gain pot needed replacing. SO I took to local music store and in the process of repairing, something got messed up and all it will do now is howl when turned on. No difference when a cord is plugged in or knobs are turned.

    Took it to another repair place and tech says the main power IC is likely the culprit. Shouldn't be too hard to fix if we can find the number on the IC. HOWEVER, the number on the IC in my amp is burned off - that's why the tech suspects it's bad.

    My question is this: can anyone pull their amp head out of the cabinet and get the number off of the IC and send it to me? SO tech can try to find a replacement? The IC is the one that is screwed to the heat sink in the back of the head.

    Or if anyone has parts to sell that are supposed to be known to work, I would consider buying them or whole amp head if price is right.

    Acoustic support does not provide any replacement parts. Period. If amp is under warranty, they send you a new one. Otherwise, you;re on your own. Something to remember if you are considering. And yes I know there are better etc amps out there. But this one works for us and I don't have any money to invest in a new amp right now.

    Thanks so much
    Randy
     
  2. Cirk

    Cirk

    Joined:
    Jan 16, 2011
    Location:
    Newport News, VA
    Hi Randy,
    Where are you located?
     
  3. 66musicmaster

    66musicmaster

    Joined:
    Nov 1, 2010
    Mt Airy, NC - foot of the BR mountains near VA line.

    Randy
     

Share This Page