1. Welcome to TalkBass, the Premier Bass Player Community and Information Source. We've been uniting the Low End Since 1998!

    We're glad you've found us. Register a 100% Free Account to post and unlock tons of features.

Hughes & Kettner Fortress preamp question (HELP!)...

Discussion in 'Amps [BG]' started by UntuchablSS, Jan 28, 2013.


  1. UntuchablSS

    UntuchablSS

    Joined:
    Nov 7, 2011
    Hello everyone...

    I'm very familiar with the Fortress from many years ago but to be honest I never owned one. Now that I do, I'd like a manual for it...not that I haven't checked EVERYWHERE for one.

    any one have one ?

    But for today, I just wanted to ask whether anyone here is running it bi-amp'd ?

    I connected it into my Carvin R600 amp (which is a bi-amp'd combo) sending the Fortress bi-amp'd signals into the Carvin's LO and HI amp returns.

    When I play it that way, I get a reverb sounding howl through the cabinet. More interestingly, when I try to sweep the H&K's bi-amp cutoff point, a sound like a modulating delay pedal with harmonic overtones and feedback comes through the cabinet.

    When I just take the signal out of the preamp using the line out and into just the LO amp return on the Carvin, it sounds fine. Not great, but it's not howling or modulating or causing any feedback.

    Any ideas ?

    Thanks
    Val
     
  2. Krakus

    Krakus

    Joined:
    May 29, 2011
    Location:
    Toronto, Ontario, Canada
    For the H&K Fortress Manual, get in touch with Steve Das at Yorkville Sound (sdas@yorkville.com). Yorkville handles the distribution and product support for H&K in North America. However, the full manual is only available in german; a condensed version is available in english.
     
  3. Krakus

    Krakus

    Joined:
    May 29, 2011
    Location:
    Toronto, Ontario, Canada

Share This Page