I hate to say SVT Pro7 ????

Discussion in 'Amps [BG]' started by johnnynitro, Aug 15, 2013.


  1. johnnynitro

    johnnynitro

    Joined:
    Jan 14, 2012
    I have a SVT Pro7 rev C With two SVT 410 He's I have had it a little over a year, It's never left my apartment, Been played at low volume. Was playing it yesterday heared a pop and that was it! No sound,No power, no light ! Checked everything that I could ! Have three auditions next week ! I really like this thing,But now once I get it fixed I'll never fully trust it again !!! I have been playing for over 40 years ! And have played thru some real crapy amps in my day.But never one thats just flat stoped working !! And as new as it is ! Im not trying to bash Ampeg !!!! But Im at a loss now ! Hell my GK rb400 lasted for over 20 years of abuse ALWAYS WORKED !!!!!!!!!! Thanks for letting me vent !!!!
  2. B-string

    B-string Supporting Member

    Joined:
    Nov 21, 2008
    Location:
    Lake Havasu City, Az USA
    Well at least you have company in your frustration with LOUD/Ampeg SVT 7 "Pro"s. Have seen the same here a few times.
  3. georgestrings

    georgestrings Banned

    Joined:
    Nov 5, 2005
    Amplague strikes again...

    I'm sure one of their supporters will be along anytime now to tell us it's "only 1%"...

    Best of luck, OP - I wouldn't buy an Ampeg amp unless it was all tube...


    - georgestrings
  4. B-string

    B-string Supporting Member

    Joined:
    Nov 21, 2008
    Location:
    Lake Havasu City, Az USA
    Don't forget the "Mine has been flawless" folks. Great thing to rub in the face of someone with a failure.
  5. Register to disable this ad
  6. arai

    arai

    Joined:
    Jul 16, 2007
    And the user error folk ;)

    Sorry OP sucks when something like this happens
  7. IPYF

    IPYF

    Joined:
    Mar 31, 2011
    Location:
    Melbourne, Australia
    This sucks. At least have a crack at politely getting in touch with Ampeg customer service, quote your serial number and see if they'll help out. I know there's been a lot of negativity surrounding the CS of this brand but I think it's always a good idea to have a crack regardless.
  8. VeganThump

    VeganThump

    Joined:
    Jun 29, 2012
    Location:
    South Jersey
    That's too bad bud, sorry to hear about your amp. It's a shame because its really only about a 1% failure rate and mine has been flawless since I got it, perhaps your problem was user error?
  9. drpepper

    drpepper Supporting Member

    Joined:
    Jul 20, 2009
    Location:
    Columbia, Maryland
    Mine was flawless for the 6 months I had it. I got a message this week from the person I sold it to 8 months ago. It went up over the weekend. I assume since he said Saturday night, it was at a gig :meh:
  10. drpepper

    drpepper Supporting Member

    Joined:
    Jul 20, 2009
    Location:
    Columbia, Maryland
    [​IMG]

    The trifecta
  11. Mvilmany

    Mvilmany

    Joined:
    Mar 13, 2013
    Did you check the fuse?
  12. johnk_10

    johnk_10 vintage bass nut Supporting Member

    Joined:
    Feb 16, 2008
    Location:
    Thousand Oaks, CA
    Disclosures:
    John K Custom Basses
    mine worked perfect for a year and then one day it popped and went dead. it's sitting in a corner of my house-DEAD. it's too bad, since I liked it while it worked.
  13. majortoby

    majortoby

    Joined:
    Jul 2, 2009
    Location:
    Tampa, Fl USA
    I don't get it. It's probably the best-sounding I've ever layed hands on, yet it's shaping up to have the worst track record of any amp I've ever seen.

    Alas, she is the best AND the worst.


    Maybe the Bugera version will have these issues ironed out? ;)
  14. IPYF

    IPYF

    Joined:
    Mar 31, 2011
    Location:
    Melbourne, Australia
    That would actually be a really good place to start.
  15. MeLikeBass

    MeLikeBass Supporting Member

    Joined:
    Oct 20, 2010
    Location:
    Indianapolis, IN
    Had the same exact thing happen to me. Bought one in december of 2011, died in early 2012, POP and dead. Of course LOUD made good on the warranty with a REV C model and all was good. Then in August 2012, I think, same POP, same dead head... LOUD returned my money and I moved on. Bad head, great customer service. And yes, fuse was checked, Loud asked me the same thing :)

    I will say I loved the head and have an Ampeg BA115 combo that I use for practice and never had any problems with it.
  16. slade

    slade

    Joined:
    Apr 5, 2001
    such a bummer. Mine has been flawless and pushed very hard- guess you guys are starting to make me nervous. For the record it's the first Ampeg I've owned, although I've gigged them as backlines for years. After using it and the Streamliner multiple times on the same nights live there was no comparison. That said, if it blew up I wouldn't buy another I suppose. Not shocked to see the same ampeg haters jumping in here, but that does as little to help the OP as the Ampeg fanboys. Hope you get your gear straightened out quickly my friend- sorry you're ampless
  17. andrew

    andrew

    Joined:
    May 20, 2000
    Location:
    Vancouver BC/Pacific Northwest
    Disclosures:
    Endorsing Artist: Aguilar Amplification, Regenerate Guitar Works
    What amp are you doing your pedal recordings with now John?
  18. johnk_10

    johnk_10 vintage bass nut Supporting Member

    Joined:
    Feb 16, 2008
    Location:
    Thousand Oaks, CA
    Disclosures:
    John K Custom Basses
    either my GK 1001 RBII or my Yamaha BT500H.
  19. andrew

    andrew

    Joined:
    May 20, 2000
    Location:
    Vancouver BC/Pacific Northwest
    Disclosures:
    Endorsing Artist: Aguilar Amplification, Regenerate Guitar Works
    Is that what is on your Gamma Bass OD pedal sample, the GK or Yamaha?
  20. worxforme

    worxforme Self Actualized Bad Speller Supporting Member

    Joined:
    Dec 10, 2009
    Location:
    LAnsing MI
    I hope the last pf500 thread has quelled the supporters spouting hollow words filled with delusional data.

    Seriously, I'm super sorry OP and to set the record straight I'm not an Amplague hater, I dislike any company without integrity, nothing more.

    Let me know if they don't take care of you and I'll donate $50 toward repairs if you promise to sell it afterwords and get yourself an amp by another company... One that stands behind it's products with actions, not words.
  21. blowinblue

    blowinblue official non-user of Fender and Ampeg Supporting Member

    Joined:
    Nov 29, 2006
    This is possibly the best Ampeg related post since the inception of Talkbass. So few words...but it says so much.

    To be truthful I haven't had one bit of trouble with their amps since 1980. That was the year I parted with my great sounding but overweight, underachieving B15-N. Through some incredibly good fortune I've been able to resist the lure of the 'Ampeg' name all of these years. Maybe that's why almost every one of my posts includes a smiley face. :)

    M. M.

Share This Page