1. Welcome to TalkBass 2014! If you're new here, we just went through a major site upgrade. Please post all concerns and bugs to the Forum Usage Issues forum. We will be monitoring that forum. Thank you for all of your feedback.

    The TalkBass iphone/android app is NOT WORKING currently. We're working on it. Tapatalk IS working, so if you need to use an app, use Tapatalk. Try using your browser though - TalkBass is now 100% responsive to your phone/tablet screen size ;)

    Please read the TalkBass 2014 FAQ for lots of great info on the new software.

Ibanez BTB 5 preamp

Discussion in 'Pickups & Electronics [BG]' started by NevadaNed, Jun 26, 2013.

  1. NevadaNed

    NevadaNed

    Joined:
    Nov 28, 2010
    Likes Received:
    0
    I just bought an Ibanez BTB 5. It's got Bartolini pickups and preamp in it. The preamp runs on 18vdc. It seems that with 18vdc the output signal should need to be padded, however when I plug it into my Active input on my amp (with the 10db pad) I get hardly any signal into the amp, and what's coming out is very wimpy. When I plug it into the unpadded input I get more sound, but it's still pretty wimpy. With an 18vdc preamp I should have WAY more signal in than I need, but as noted.....very very wimpy. There's no pull out Active/Passive switch in the volume control, and it's got the 3 band eq with the mids having a semi-parametric stacked knob config. The serial number indicates it was made in 2006. Any body else have this kind of problem with the Bart preamp, and if so what turned out to be the cause, and how'd you fix it?

    Before anybody suggests changing the batteries.......already done.

Share This Page