Ibanez website down??

Discussion in 'Basses [BG]' started by Root 5, Jan 27, 2013.


  1. Root 5

    Root 5

    Joined:
    Nov 25, 2001
    Location:
    Earth - the Canadian part of it.
    I've been trying to get on the Ibanez website ( The USA & Canada sites) for three days now.

    Is anyone else having difficulty getting on there??
    Thanks!
  2. JxBass

    JxBass Supporting Member Supporting Member

    Joined:
    Aug 5, 2008
    Just tried it for you - worked fine.
  3. FrenchBassQC

    FrenchBassQC Supporting Member

    Joined:
    Jul 13, 2011
    Location:
    Gatineau QC CA
    Worked for me.
  4. Thomas Kievit

    Thomas Kievit Thou shall not F*** up the groove Supporting Member

    Joined:
    May 19, 2012
    Yes I had the same problem a couple of times too. Probably some maintenance since there are a lot of new instruments this year.
  5. Register to disable this ad
  6. tmdazed

    tmdazed

    Joined:
    Sep 29, 2012
    Both work fine for me , maybe try cleaning out your Cache. It could be due to increased traffic or updating from NAMM too
  7. evil-g

    evil-g Supporting Member

    Joined:
    Feb 3, 2009
    Location:
    Pittsburgh,Pa.
    I've been trying too. I wonder if using an iPad has something to do with it.
  8. stepswork4me

    stepswork4me Supporting Member

    Joined:
    Mar 29, 2010
    Location:
    Across the creek from Cinci
    It's been hit or miss, including the JP site, for two days. I guessed increased traffic.
  9. ReiPsaeg

    ReiPsaeg

    Joined:
    Dec 1, 2012
    Location:
    Rochester, NY
    I try to load their USA website and keep getting a white page with a red exclamation mark and a bunch of strange symbols.
  10. 20db pad

    20db pad

    Joined:
    Feb 11, 2003
    Location:
    I been everywhere, man...
    Not loading for me, on a Mac.
  11. TolerancEJ

    TolerancEJ

    Joined:
    May 27, 2010
    Location:
    Vancouver, BC Canada
    I've also been having trouble watching YouTube videos, likely with all the increased NAMM traffic.
  12. Cadfael

    Cadfael

    Joined:
    Jan 4, 2013
    Location:
    Germany, EU
    Don't think it's the NAMM ...
    Maybe a hacker attack???

    The German site coming from ibanez.com is also not available.
    Typing the direct German address www.ibanez.de is no problem.

    Maybe it is a main server problem? Ibanez worldwide surely has its own servers in the USA or Japan. This system can also break down because of a computer or energy failure ...
  13. Root 5

    Root 5

    Joined:
    Nov 25, 2001
    Location:
    Earth - the Canadian part of it.
    I'm glad I'm not alone with this issue! I can't get on that website no matter what I do! I've probably tried 15 times in the last 3 days with no luck.

    I assumed that maybe it was because Ibanez is updating the website and/or too much traffic.

    We'll see what happens.
  14. IngerAlb

    IngerAlb

    Joined:
    May 11, 2007
    The website is sluggish as hell and most pages don't load. I was able to see the EU pages for a couple of minutes, but the US & Japan ones are down.
  15. sevdog

    sevdog

    Joined:
    Mar 2, 2008
    Location:
    ATX
    I think they're updating it and so it's going up and down and certain pages are up then down.
  16. wvbass

    wvbass Supporting Member

    Joined:
    Mar 1, 2004
    I noticed that it now redirects to the co.jp site and is ridiculously slow from an iPad.

Share This Page