1. Welcome to TalkBass 2014! If you're new here, we just went through a major site upgrade. Please post all concerns and bugs to the Forum Usage Issues forum. We will be monitoring that forum. Thank you for all of your feedback.

    The TB Android app is working, you may need to uninstall/reinstall. The iPhone app is now updated and should work after you upgrade. TalkBass is responsive to any screen size, so we recommend using your mobile browser for full functionality.

    Please read the TalkBass 2014 FAQ for lots of great info on the new software.

Jazz Bass Grounding/Wiring Problems

Discussion in 'Pickups & Electronics [BG]' started by Think deep, Nov 15, 2012.

  1. Think deep

    Think deep

    Joined:
    Jun 27, 2012
    Likes Received:
    0
    Okay, I realize there are a hundred threads on this already but I feel as if I've read them all and still can't figure out my problem! I have a used Fender Fretless Jazz Bass MIM that I put Fender N3 Jazz Bass PUPs in. I shielded it with the Stewmac paint, put in some cavity grounds, brass cavity shielding plates, have checked and tried to establish a better ground underneath the bridge with the bare wires, have reconfigured and wired as many different ways as possible and still have a crazy hum. My P-Bass MIA 2011 does not have this problem in the same room on the same amp with the same cables. I read a thread where a guy said he got his bass dead quite with the brass cavity shielding plates from mikecd1,
    "
    Having already had this problem on my modded Jazz bass I opted to install a brass cavity ground plate I bought from darren riley (he stocks ALL Fender parts and ships same day priority). One solder connection to the cavity ground and the plate underneath the rear J pickup was installed. My bass is dead quiet and I am enjoying it for the first time. If your Jazz bass still has some hum after shielding I would suggest a brass cavity grounding plate under both pickups. You might accomplish the same thing by grounding the pole pieces with a strip of copper and a wire to the cavity ground..."

    Here is the link to that thread.http://www.talkbass.com/forum/f38/american-deluxe-jazz-pbass-ground-hum-noise-problem-solved-802153/

    My question being (and I hate to sound electronics illiterate) but what are the "pole pieces" he is talking about? And if someone has had this problem and solved it could you post pictures? Thanks!
  2. SGD Lutherie

    SGD Lutherie Supporting Member

    Joined:
    Aug 21, 2008
    Likes Received:
    2
    Disclosures:
    Owner, SGD Music Products
    How did you wire up the N3s? Which wire went to hot and which to ground?

    Also, did you run a ground wire to the shielding paint?

Share This Page