John East Musicman Pre problem

Discussion in 'Pickups & Electronics [BG]' started by tonymcbony, Dec 13, 2012.


  1. tonymcbony

    tonymcbony

    Joined:
    Mar 21, 2006
    Hi folks,

    got a bit of a conundrum with my John East Preamp in my Stingray.

    The treble knob, when fully cranked, buzzes like crazy, like there's voltage going across it or something. The weird thing is that if you back off slightly, it disappears completely and the rest of the range is fine.

    Any idea what on earth this could be?
     
  2. 4-string

    4-string Supporting Member

    Joined:
    Jul 23, 2006
    Location:
    Norway
    Have you tried asking John East himself? IME, he is very helpful and responds to emails swiftly.
     
  3. tonymcbony

    tonymcbony

    Joined:
    Mar 21, 2006
    Yeah, just sent him an email, just wondering if it was an easy fix that someone on here had already encountered
     
  4. SGD Lutherie

    SGD Lutherie Banned

    Joined:
    Aug 21, 2008
    Location:
    Bloomfield, NJ
    Disclosures:
    Owner, SGD Music Products
    It might just be boosting noise being picked up by the pickup or wiring. Is the bass shielded?
     
  5. Register to disable this ad
  6. tonymcbony

    tonymcbony

    Joined:
    Mar 21, 2006
    I think it's shielded, I'll have to check. It's kinda weird that it's only at the very top of it's range; it almost acts like a switch, full on = big hiss, roll back very slightly and it disappears.
     
  7. John East

    John East

    Joined:
    Jan 10, 2002
    Location:
    Oxford UK
    Disclosures:
    Owner of E-Pro & East UK
    I emailed you ref this issue, did you get my email?
     
  8. tonymcbony

    tonymcbony

    Joined:
    Mar 21, 2006
    Yes indeed, thanks John. Nice of you to comment here as well (I made this thread before I emailed you).

    Problem lay between soldering iron and chair...
     

Share This Page