1. Welcome to TalkBass 2014! If you're new here, we just went through a major site upgrade. Please post all concerns and bugs to the Forum Usage Issues forum. We will be monitoring that forum. Thank you for all of your feedback.

    The TalkBass iphone/android app is NOT WORKING currently. We're working on it. Tapatalk IS working, so if you need to use an app, use Tapatalk. Try using your browser though - TalkBass is now 100% responsive to your phone/tablet screen size ;)

    Please read the TalkBass 2014 FAQ for lots of great info on the new software.

K & K Preamp question

Discussion in 'Rockabilly [DB]' started by FatBoutedGirls, Feb 23, 2014.

  1. FatBoutedGirls

    FatBoutedGirls

    Joined:
    Jun 8, 2013
    Likes Received:
    0
    So I've been using a K&K 2 channel mixer/preamp for my bass max pickup and clicky before it runs to my amp. Last gig I had trouble getting the clicky loud enough, but the bass signal was strong. I think I remember this happening just before I needed to replace the 9v battery. Is the clicky the first thing to go when the battery starts to die?
  2. squarewave

    squarewave Supporting Member

    Joined:
    Jun 16, 2004
    Likes Received:
    0
    I don't think so. Did you check to make sure the transducer hasn't come loose from the underside if the fingerboard? Even a little gap will really mess with it.
  3. Studiodawg

    Studiodawg

    Joined:
    Oct 25, 2007
    Likes Received:
    0
    Positioning of clicky pickup is finicky. Experiment with only the clicky pickup volume up and move the pickup until you find the spot that makes you happy.
  4. FatBoutedGirls

    FatBoutedGirls

    Joined:
    Jun 8, 2013
    Likes Received:
    0
    Yep, looks like I just needed to get the clicky pressed on to the fingerboard better. Thanks for the insight.

Share This Page