1. Welcome to TalkBass 2014! If you're new here, we just went through a major site upgrade. Please post all concerns and bugs to the Forum Usage Issues forum. We will be monitoring that forum. Thank you for all of your feedback.

    The TalkBass iphone/android app is NOT WORKING currently. We're working on it. Tapatalk IS working, so if you need to use an app, use Tapatalk. Try using your browser though - TalkBass is now 100% responsive to your phone/tablet screen size ;)

    Please read the TalkBass 2014 FAQ for lots of great info on the new software.

Lakland DJ owners, please help

Discussion in 'Pickups & Electronics [BG]' started by cheezewiz, Feb 22, 2014.

  1. cheezewiz

    cheezewiz Supporting Member

    Joined:
    Mar 27, 2002
    Likes Received:
    0
    Could someone take a minute as a favor to me, and take a pic of the wiring on your Lakland DJ. I received mine after it has had pickups swapped in and out, and I believe it's wired up incorrectly. There is a HUGE bottom end drop out when both pickups are at full, and a huge bottom increase when the neck pickup is rolled off just slightly. I'm familiar with jazz style basses and the eccentricities of the pickups in relation to each other. This is much more than "normal".

    I'm perfectly capable of rewiring, I just need a pic or a diagram to go by.

    Thanks.
  2. Bobster

    Bobster

    Joined:
    Mar 27, 2006
    Likes Received:
    1
    Of of the pickups is out of phase. Reverse the leads on one of the two. Doesn't matter which one.

    All the best,

    Bob
  3. cheezewiz

    cheezewiz Supporting Member

    Joined:
    Mar 27, 2002
    Likes Received:
    0
    Thanks Bob...I'll give it a go
  4. nervous

    nervous Supporting Member

    Joined:
    Jan 5, 2010
    Likes Received:
    0
    You get this sorted? If not PM me. I'll shoot some pics of what I took out.
  5. cheezewiz

    cheezewiz Supporting Member

    Joined:
    Mar 27, 2002
    Likes Received:
    0
    I got sorted thanks! I ended up putting all new guts in it. Works fine now!

Share This Page