1. Welcome to the premier online community and classifieds for bass players!

    Register a free account to post, remove lots of ads, and more!

Looking for help with faulty pedal board

Discussion in 'Pickups & Electronics [BG]' started by wafu_vasco, Dec 29, 2013.


  1. Hello All,
    Hope you had a great Christmas and are looking forwards to New Year!

    I've recently had a problem develop with my Korg Toneworks AX3000B pedal board. It's about 4 or 5 years old now so well out of warrantee. Basically, the tone seems to fade in and out of treble, so whilst playing it will suddenly loose that top end definition and then after 10 seconds or so fade back up to normal settings. There is no change on the display whilst this happens. I've tried different basses and playing direct to amp; it is definitely the pedal board.

    Also, for the past year or two, it had a habit of changing channel without me telling it to. It would select one of the default settings which would then show itself on the display, but would go back to normal the moment I hit the channel select I wanted, so I've lived with it as a minor annoyance.

    I'm not sure if the two problems are completely independent and it's certainly beyond me; has anybody got any ideas as to what might be wrong with it? Is it something which can be fixed, or shall I cut my losses and just get some new pedals?

    Thanks very much!
     
  2. Alivefor5

    Alivefor5

    Jul 17, 2006
    Indiana
    You'll get better mileage on these questions over in the "effects" forum.
     
  3. Thanks for the help, I'll re-post there.