1. Welcome to TalkBass 2014! If you're new here, we just went through a major site upgrade. Please post all concerns and bugs to the Forum Usage Issues forum. We will be monitoring that forum. Thank you for all of your feedback.

    The TB Android app is working, you may need to uninstall/reinstall. The iPhone app is now updated and should work after you upgrade. TalkBass is responsive to any screen size, so we recommend using your mobile browser for full functionality.

    Please read the TalkBass 2014 FAQ for lots of great info on the new software.

Mag/piezo phasing / new pickup recommendations

Discussion in 'Pickups & Electronics [BG]' started by Justyn, Jan 4, 2013.

  1. Justyn

    Justyn Supporting Member

    Joined:
    Jun 24, 2002
    Likes Received:
    0
    Hi folks,

    I recently changed out the previous bridge and undersaddle transducer on my fretless Stambaugh with a Graphtech-equipped Hipshot bridge. I used Graphtech's Acoustiphonic preamp to mate the bridge to my Bartolini P25CBC dual coil humbucker. All wiring was checked by my local luthier.

    Here's the issue I'm having:

    The Acoustiphonic preamp features a mid/dark switch and when I have it set to 'mid,' and I dial in my magnetic pickup, the sound gets thin and uneven.
    the folks at Graphtech, who have been super helpful as I've worked out a few user error issues, suggested it could be a phasing issue, so I reversed the leads from the pickup. That corrected the phase issue, but now I have a ground hum from the mag pickup whenever I'm not touching the strings.

    I have a Carvin humbucker that works just fine, but it's one of the new radiused models and I don't think the curvature is a proper match for my fingerboard, so it's not an ideal solution.

    Any suggestions, advice, replacement mag recommendations, etc.?

    - thanks

Share This Page