MXR Bass Octave Deluxe crapping out

Discussion in 'Effects [BG]' started by bass4u, Feb 12, 2013.


  1. bass4u

    bass4u Supporting Member

    Joined:
    Jul 7, 2007
    Location:
    maryland,usa
    I have a month old MXR BOD that started crapping out on me. When engaging the Mid switch a high pitch squealing sound is present from the pedal as well as an extremely distorted signal. Anyone experience this with the BOD? I sent an email to MXR 2 days ago describing the problem but haven't received a reply yet. This is my first MXR pedal and maybe my last. LOL
  2. macburn

    macburn

    Joined:
    Mar 3, 2012
    Location:
    Montreal, Qc
    I don't have the same issues, but the MXR BOD is my first and last MXR pedal.
    Mine will randomly just mute the sound, or very low signal.

    It always emits LFO noise from other pedals, even bypassed (unplugging the power fixes it).

    If you search the forums here, you'll find other complaints too.
  3. Floyd Eye

    Floyd Eye

    Joined:
    Feb 21, 2010
    Location:
    St. Louis
    Dunlop will repair or replace the pedal at no charge. The first one (BOD) I got had issues. I shipped it to them, they replaced the guts and shipped it back. They even paid for the shipping. The replacement has been on my board for almost 2 years with no problems.
  4. Bermel

    Bermel Supporting Member

    Joined:
    May 11, 2001
    Location:
    Spain
    Mine works flawlessly.

    However, poor communication from Dunlop side would be a no-no, no matter how good their replacement policy or repair service claims to be.

    Have you tried different ways to contact them?
  5. Register to disable this ad
  6. Floyd Eye

    Floyd Eye

    Joined:
    Feb 21, 2010
    Location:
    St. Louis

    2 days ago was Sunday. Some places recognize today as a holiday too.
  7. bass4u

    bass4u Supporting Member

    Joined:
    Jul 7, 2007
    Location:
    maryland,usa
    I'm going to wait a few more days for a response from MXR.
  8. Floyd Eye

    Floyd Eye

    Joined:
    Feb 21, 2010
    Location:
    St. Louis

    I used the email address on the warranty card. I would guess the whole ordeal took 3 weeks from the time the problem developed to the time I got it back.
  9. bass4u

    bass4u Supporting Member

    Joined:
    Jul 7, 2007
    Location:
    maryland,usa
    Still waiting for my "repaired" MXR BOD to show up back from MXR. (I had to pay for shipping to them) Internal electrical failure in two months of ownership makes me less than enthusiastic about ever buying another MXR pedal.

    I've been using pedals for the past 15 years and the BOD was my first MXR pedal, and the only one that has ever failed.
  10. Floyd Eye

    Floyd Eye

    Joined:
    Feb 21, 2010
    Location:
    St. Louis
    Hmm. I have owned tons of MXR pedals over the years. I have had way more Boss pedals kill themselves than MXR. Can't believe they are making you eat the shipping though. That sucks.
  11. mmbongo

    mmbongo I like turtles. Supporting Member

    Joined:
    Aug 5, 2009
    Location:
    Upstate, South Carolina
    I bought a brand new one that had noise issues when engaged. Sounded awful. Exchanged it for an Aguilar Octamizer. My MXR BEF has been rock solid, though.

Share This Page