Need to fix my Morley Optical Volume pedal

Discussion in 'Effects [BG]' started by Mesa XI, Nov 28, 2012.


  1. Mesa XI

    Mesa XI

    Joined:
    Feb 25, 2009
    The pedal was very nice while it worked, which was about the first week I owned it. After that setting the pedal to full volume still isn't half way to full volume. I don't know what went wrong. I recently bought a soldering iron and was thinking maybe if I opened it up I could figure out what's wrong. Anyone know how to fix that?
  2. lowfreq33

    lowfreq33

    Joined:
    Jan 27, 2010
    Location:
    Nashville
    Disclosures:
    Endorsing Artist: Genz Benz Amplification
    How are you powering it? Battery? These aren't passive, so if the battery gets low you'll lose volume.
  3. Mesa XI

    Mesa XI

    Joined:
    Feb 25, 2009
    No, I use a direct power source.
  4. lowfreq33

    lowfreq33

    Joined:
    Jan 27, 2010
    Location:
    Nashville
    Disclosures:
    Endorsing Artist: Genz Benz Amplification
    Well, if you're not experienced with electronics you probably won't be able to diagnose it yourself. Did you purchase it new?
  5. Mesa XI

    Mesa XI

    Joined:
    Feb 25, 2009
    Yea, but it was a long while back and I don't have the receipt. I figure it's not the end of the world if this thing doesn't get fixed, it was relatively inexpensive. I have a ton of pedals so I figure I eventually am going to have to learn to fix them, thought maybe this would be a good way to learn.

Share This Page