1. Welcome to TalkBass 2014! If you're new here, we just went through a major site upgrade. Please post all concerns and bugs to the Forum Usage Issues forum. We will be monitoring that forum. Thank you for all of your feedback.

    The TB Android app is working, you may need to uninstall/reinstall. The iPhone app is still pending approval by Apple. If you haven't yet, try using your mobile browser - TalkBass is responsive to any screen size.

    Please read the TalkBass 2014 FAQ for lots of great info on the new software.

Peavey TNT 115S pulsing sound

Discussion in 'Amps [BG]' started by Jdav, Jan 31, 2014.

  1. Jdav

    Jdav

    Joined:
    Jan 31, 2014
    Likes Received:
    0
    I bought this amp in 1998, A few years into it and started developing this power oscillating sound. It would be fine and then all of a sudden it would give me a pulsing sound and my bass would be distorted. It happened at a couple shows, so eventually I just purchased a new bass amp, I was young and wanted a monster amp anyway. Anyway I recently started playing keyboards in a band and I started using that old bass amp, I hooked it up and it seemed fine but after an hour or two of playing organ through it, it started doing that pulsating and distorted sound again. I can't seem to get the head out of the combo to look at, it is held in with 30 invisible screws made of kryptonite apparently, but I was wondering if anybody knew what this problem could be from. The distortion makes me think that it's probably a short and maybe that could explain the warbling pulsating sound as well, but I really have no idea about repairing bass amps somebody help me out please, If I can't get the head to work that's fine, I've been using the speaker part of this combo on it's own for years now.
  2. B-string

    B-string Supporting Member

    Joined:
    Nov 21, 2008
    Likes Received:
    12
    PM BbbyBld he should be of big help.
  3. sjeverett

    sjeverett

    Joined:
    May 10, 2013
    Likes Received:
    0
    I have the same amp and same problem. Puull out the speaker and hold up to the light. I bet you have a bunch of pinholes. I patched the holes with nailpolish and its fixed....for now.
  4. sjeverett

    sjeverett

    Joined:
    May 10, 2013
    Likes Received:
    0
    Time for a new repacement basket.
  5. Jdav

    Jdav

    Joined:
    Jan 31, 2014
    Likes Received:
    0
    Do you mean in the cone? I will look, but years ago I opened up the amp unhooked the speaker and attached it to an external 1/4 " Input and started using that speaker is part of my PA rig, the speaker seem to be holding up fine but next time I'm at my practice space I will check out the cone to see if it has pinholes in it.
  6. sjeverett

    sjeverett

    Joined:
    May 10, 2013
    Likes Received:
    0
    Check the outer edge that flexes. I've had a few Shiner Bocks and cant remember the technical term for that. Mines holding up ok, but I hope to get a new cone for it soon. Thats what I like about the black widow and scorpion speakers. No need to replace the whole speaker.
  7. Jdav

    Jdav

    Joined:
    Jan 31, 2014
    Likes Received:
    0
    Will do when I get to my space. Glad to hear someone's drinking a good Texas beer!
  8. Catanova

    Catanova Supporting Member

    Joined:
    Apr 7, 2011
    Likes Received:
    0
    If you find that the speaker is not faulty, FYI: Removing the guts of a Peavey amp is a process that requires some patience, dis-assembling these amps is a chore. Some Pointers:

    When pulling the speaker grillcloth frame, the tenacious velcro will likely require a small prying tool.

    The chassis will need to be dis-connected from the speaker.

    Usually can't remove the circuit boards without removing ALL the retaining nuts from the pots and jacks. These pots/jacks are attached to the printed circuit boards (PCB's).

    There will be ribbon cables between parts of the (PCB's) that need to be dis-connected. Label as you dis-connect.

    Take note of the PCB's connections to each other. These are usually "jumper wires" that connect one board to the next. Many problems originate here, these wires are bent to conform to the chassis. They are known to break, but they can be soldered easily if they are broken.

    Look for "burn marks" on any PCB that indicate a component has failed. Keep in mind that replacing a "failed" component on a PCB does not guarantee that other components in that trace have not also been damaged.

    That sounds like a capacitor problem, or a break between PCB's.
  9. sjeverett

    sjeverett

    Joined:
    May 10, 2013
    Likes Received:
    0
    I'm just glad Shiner Bock has made it to the Heart of Texas. When I first moved back from San Marcos in 97, I looked every where for it. I asked a lady at a store and she said "Honey, we dont have any IMPORT beer!" Shiner Bock and Shiner Light Blonde are my go to beers.
  10. sjeverett

    sjeverett

    Joined:
    May 10, 2013
    Likes Received:
    0
    I ordered a replacement from Carvin thru their ebay store. $69 with free shipping. Came in today. What a difference! I'm in love with my amp again. It was cheaper to replace the whole thing than to get a replacement basket for the scorpion.

Share This Page