1. Welcome to TalkBass, the Premier Bass Player Community and Information Source. We've been uniting the Low End Since 1998!

    We're glad you've found us. Register a 100% Free Account to post and unlock tons of features.

Rolls PM351 issues - distorted instrument channel

Discussion in 'Live Sound [BG]' started by Rocksolid, Apr 7, 2014.


  1. Rocksolid

    Rocksolid

    Joined:
    Mar 19, 2008
    Location:
    Adelaide, South Australia
    Had my rolls box for a few years now. Last year - just before the Christmas season started I had issues with the instrument channel sounding all distorted. Took it to my Tech, there was a blown chip on the PCB for this channel, switched it out for a better quality one and had no issues. Until yesterday...

    Did a gig on the weekend and had the same issue again, but worse. If I turned up the distorted instrument channel, signal from all channels would cut out. fortunately I found a work around.

    I spoke to the Tech today, and he said it is unlikely that it is the chip he replaced, and that it could be another chip in that channel. When I get it to him he will suss it out. If it is the same chip, I'll probably ditch the unit for a new one or go for a JTS PMM4, if it is a different chip, I'll probably get it replaced and persist with it.

    My Tech has weaved magic for me over the years. I have no reason to doubt his work.

    Has anyone ever had this issue, and if so, did you contact Rolls, or get any feedback on it? I've emailed Rolls but no word so far.
     
  2. Rocksolid

    Rocksolid

    Joined:
    Mar 19, 2008
    Location:
    Adelaide, South Australia
    I'll take that as a no...
     

Share This Page