1. Welcome to TalkBass, the Premier Bass Player Community and Information Source. Register a FREE Account to post and unlock tons of features!

Spector help needed

Discussion in 'Pickups & Electronics [BG]' started by alembicguy, Feb 20, 2013.


  1. alembicguy

    alembicguy Lone Wolf Miner Supporting Member

    Jan 28, 2007
    Minnesota
    If anyone can help me out I would be greatly appreciated. I removed a EMG BTS and purchased a Tone Pump to install. I've done it like they suggest and I am getting nothing at the jack, only the local radio station not the bass. Any thoughts could you PM me. Here are some pics of the Tone Pump installed. Let me know if anybody sees a wire in the wrong ImageUploadedByTapatalk1361412153.625153.jpg ImageUploadedByTapatalk1361412168.931683.jpg
     
  2. Sponsored by:

  3. GBassNorth

    GBassNorth

    Dec 23, 2006
    SoCal
    Post this on the Talkbass Spector Club thread and you'll have an answer in minutes.
     
  4. alembicguy

    alembicguy Lone Wolf Miner Supporting Member

    Jan 28, 2007
    Minnesota
    Couple more pics. Once again if anybody can see a wire in the wrong spot please let me know. ImageUploadedByTapatalk1361412271.239302.jpg ImageUploadedByTapatalk1361412295.222996.jpg
     
  5. alembicguy

    alembicguy Lone Wolf Miner Supporting Member

    Jan 28, 2007
    Minnesota
  6. GBassNorth

    GBassNorth

    Dec 23, 2006
    SoCal
    Just noticed you already posted in the Spector thread, I'm sure you'll get an answer there.
     
  7. alembicguy

    alembicguy Lone Wolf Miner Supporting Member

    Jan 28, 2007
    Minnesota
    Nothing from there yet, not sure if I was supposed to post in the club thread or not.
     
  8. Kmonk

    Kmonk

    Oct 18, 2012
    South Shore, Massachusetts
    Disclosures:
    Endorsing Artist: Fender, Spector, Ampeg, Curt Mangan Strings
  9. alembicguy

    alembicguy Lone Wolf Miner Supporting Member

    Jan 28, 2007
    Minnesota
    Spoke with him earlier today and all he could suggest was looking at wiring diagrams on their Facebook page. I've sent the same pics to jimmy in their shop and hopefully will here something from him. I've got it wired just like their diagrams, just wondering if there is a way I can test and make sure the preamp isn't suspect.
     
  10. cjmodulus

    cjmodulus Supporting Member

    Jul 15, 2010
    You can probably pm limaguy, he's installed a few tonepumps iirc. Of course, once someone knowledgeable sees your post in the club thread you'll likely have an answer soon. It's kind of been a slow night in there for some reason...
     
  11. worshiprocker

    worshiprocker Tonepump Junkie

    Aug 12, 2011
    Mesa, Arizona
    Disclosures:
    Endorsing Artist: Spector Basses
    maybe the jack is bad or wired wrong.... That is the only thing i can't really see. I've had barrel jacks go bad on a few basses when switching out preamps.
     
  12. alembicguy

    alembicguy Lone Wolf Miner Supporting Member

    Jan 28, 2007
    Minnesota
    Thought about that also so I just ordered one from stew Mac
     
  13. worshiprocker

    worshiprocker Tonepump Junkie

    Aug 12, 2011
    Mesa, Arizona
    Disclosures:
    Endorsing Artist: Spector Basses
    I'm sure you have done this but, have you tried a new battery?
     
  14. alembicguy

    alembicguy Lone Wolf Miner Supporting Member

    Jan 28, 2007
    Minnesota
    Yes, was hoping but no difference.
     



Share This Page