The Ampeg SVT power amp tube blues

Discussion in 'Amps [BG]' started by Pills Are Yummy, Jan 13, 2013.


  1. Pills Are Yummy

    Pills Are Yummy

    Joined:
    Dec 6, 2012
    Messages:
    609
    Location:
    Santa Rosa, California
    So I was putting some 70s USA Sylvanias in my SVT, and I thought, "what the hell, I've always wanted so see the rest of this thing from the inside." So I opened the back plate, pulled out the stock SOVTEK 6550's in there, and then it hits me: I've been gigging this thing for 6 months with 2 broken 6550's; one is cracked, with the grey stuff (zinc oxide?) all over it, and the other is just plain shattered. So what's the next step? Should I simply replace the 2 broken SOVTEK's or get a new set of end-all tubes? I really don't feel like shelling out the $350 it costs to retube, but I will if necessary (goodbye, Spector):bawl:

    Thank you in advance,

    AC
     
  2. JimmyM

    JimmyM Supporting Member

    Joined:
    Apr 11, 2005
    Messages:
    79,915
    Location:
    Apopka, FL
    Disclosures:
    Endorsing: Ampeg Amps, EMG Pickups
    I'd replace the two broken Sovteks with new Sovteks. It's not the end of the world if the tubes don't match, and I think the Sovteks are a very underrated and good tube for new production.
     
  3. T-Bird

    T-Bird

    Joined:
    Apr 29, 2007
    Messages:
    8,842
    Location:
    Finland (Northern Europe)
    Hi.


    Well, if You were happy with the amp limping along with 4 tubes, just replacing the two won't hurt any, that's for sure.
    Won't probably help any either without digging a bit deeper.

    I wouldn't be too surprised if the resistors that are supposed to protect the rest of the circuit have blown, just like they're supposed to.

    Tech time gets my vote.

    BTW, I hope that the $350 retune is just a typo. If it's not, do find another tech ;).

    Regards
    Sam
     
  4. Pills Are Yummy

    Pills Are Yummy

    Joined:
    Dec 6, 2012
    Messages:
    609
    Location:
    Santa Rosa, California
    Lol, definitely a typo. How can I tell if the transistors are blown? I thought it was the job of the fuse and the transformer to protect the rest of the circuit (excuse my noobiness)
     
  5. Register to disable this ad
  6. JimmyM

    JimmyM Supporting Member

    Joined:
    Apr 11, 2005
    Messages:
    79,915
    Location:
    Apopka, FL
    Disclosures:
    Endorsing: Ampeg Amps, EMG Pickups
    Each tube has a resistor that'll blow to protect the rest of the amp in the event of catastrophic tube blowout. I don't know much about it, but I've found it doesn't always happen when you lose a tube.
     
  7. B-string

    B-string Gold Supporting Member

    Joined:
    Nov 21, 2008
    Messages:
    16,884
    Location:
    Lake Havasu City, Az USA
    Replace to two broken tubes with like units. If the vacuum was lost in those two (white powdery glass), chances are good they stopped conducting before other damage was done.
     
  8. Pills Are Yummy

    Pills Are Yummy

    Joined:
    Dec 6, 2012
    Messages:
    609
    Location:
    Santa Rosa, California
    Thanks B-string! I love your advice, and your attitude is gold.
     
  9. BassmanPaul

    BassmanPaul Gold Supporting Member

    Joined:
    Aug 25, 2007
    Messages:
    13,847
    Location:
    Toronto Ontario Canada
    Having replaced the tubes, watch them as you come out of standby. If the tubes are operating as they should you'll see a blue glow inside the glass. That glow signifies that the tubes are passing current.

    Watch also the plates. If any show signs of a red glow you need to have the bias looked at by a tech. The "red plate" means that that tube is passing too much current.

    I would place the new tubes on the same side of the OPT primary. Either positions 1,2 or 3 OR 4,5,or 6.
     
  10. B-string

    B-string Gold Supporting Member

    Joined:
    Nov 21, 2008
    Messages:
    16,884
    Location:
    Lake Havasu City, Az USA
    The tube plate is the metal part you can see from all sides and should remain black. Good tip about the blue glow :)
     
  11. MAMMOTHvolume

    MAMMOTHvolume

    Joined:
    Apr 29, 2009
    Messages:
    1,255
    Location:
    sheffield, uk
    Personally I'd recommend replacing them all, The other valves will have considerably more wear on them and may pop fairly soon
     
  12. BassmanPaul

    BassmanPaul Gold Supporting Member

    Joined:
    Aug 25, 2007
    Messages:
    13,847
    Location:
    Toronto Ontario Canada
    And to some extent i agree with you. However this case seems to revolve around tubes that were physically damaged and not "blown".
     
  13. Seans

    Seans

    Joined:
    Jul 4, 2008
    Messages:
    320
    Location:
    Herefordshire, UK
    As mentioned earlier, I would check the resistors, it's easy and they should read correctly without other components affecting the reading.
     
  14. anonymous073020132

    anonymous073020132 Guest

    Joined:
    Dec 15, 2007
    Messages:
    427
    Location:
    USA
    Replace them all & take the unit to a good tube amp tech to check everything out. I just had my 1989 SVT II non pro retubed & checked by my Tube Amp Guy Joe Kolla in RVA. He is the man! I'm running 1990s NOS Svetlana SV6550s four Gold Lion 12AX7s & two NOS 1959 Amperex 12AU7s. Sounds like a Lion God with all that growl & its pumping around 350 watts. Get your stuff checked those tubes shouldnt be broken like that they should just burn out & mess up your sound. Their might be something seriously wrong with your head.
     
  15. Seans

    Seans

    Joined:
    Jul 4, 2008
    Messages:
    320
    Location:
    Herefordshire, UK
    Nah, just the roadie.
     

Share This Page