thump on power off B100R

Discussion in 'Amps [BG]' started by mtlbasslad, Mar 22, 2014.

  1. mtlbasslad

    mtlbasslad Supporting Member

    Apr 3, 2013
    Rawdon Quebec Canada
    Hi all, any techies out there that could suggest how to get rid of the annoying 'thump' when powering off my B100R?

    Have to say that otherwise I'm loving it as a replacement for the stolen B15N (arrgh)

    I should mention that I can read a schematic (mostly lol) & have a good relationship with my soldering iron...

    Surely I'm not the only one annoyed by this?

    Thanks in advance :help:
  2. lowend1


    Feb 15, 2005
    No worries. They all do it, Ampeg sez it's normal, and most of us B100R owners have asked the same question at one time or another. I made my phone call to SLM the day after I bought my first one when they initially came out.
  3. loendmaestro

    loendmaestro Supporting Member

    Jan 15, 2004
    Vienna VA
    Mine has always done that. It doesn't bother me because the amp sounds so amazing.

    It's just the amps way of saying "Good night."
  4. JimmyM

    JimmyM Supporting Member

    Apr 11, 2005
    Apopka, FL
    Endorsing: Ampeg Amps
    Ya, it's just capacitors discharging once you shut it off. Sometimes they make a noise. No big whoop...a lot of amps do that.
  5. Sponsored by:

  6. Charley Umbria

    Charley Umbria I'm Really a Drummer Supporting Member

    Jan 28, 2011
    Rock City, TN
    My B100R (US-built) has always popped. From what I've been told by Ampeg, "They all do that." I know that the sound wasn't going to hurt the amp, but it bugged me nonetheless.

    My solution was to have Nashville Amplifier Service install a timed relay in the amplifier. It opens the speaker circuit as soon as the power is cut, before the pop hits. It works beautifully.
  7. MegaSwing

    MegaSwing Your Obedient Bassist® Gold Supporting Member

    Nov 26, 2002
    Baltimore, MD USA
    All the Ampeg combos I've ever had do it, and they don't even do it every time. But they will never completely stop doing it, so relax.
  8. Turock

    Turock Supporting Member

    Apr 30, 2000
    I wouldn't worry about it.
  9. PolkaHero


    Jan 5, 2002
  10. bccbass


    Dec 31, 2010
    My two that I had both did that as well.
  11. anderbass


    Dec 20, 2005
    Phoenix. Az.
    I seem to recall someone claiming they're B100R stopped thumping (at power down) when they're LED bulb burned out....
  12. mtlbasslad

    mtlbasslad Supporting Member

    Apr 3, 2013
    Rawdon Quebec Canada
    Thanks to all who responded - I know it's not dangerous, just annoying :(

    But Charley nailed it - I had that relay thing in my old Dynaco HIFI rig... guess I was just blue-skying thinking that someone would give me a 'just put an 100mfd cap between there & here' solution...

    Anyway, the B100R sounds so good I almost don't miss my '65 B15N that got ripped off last year :crying:

    Ampeg rules!
  13. mtlbasslad

    mtlbasslad Supporting Member

    Apr 3, 2013
    Rawdon Quebec Canada
    OK, thanks for your patience - will try to post pics IMG_0337.jpg

    Attached Files: