1. Welcome to TalkBass 2014! If you're new here, we just went through a major site upgrade. Please post all concerns and bugs to the Forum Usage Issues forum. We will be monitoring that forum. Thank you for all of your feedback.

    The TalkBass iphone/android app is NOT WORKING currently. We're working on it. Tapatalk IS working, so if you need to use an app, use Tapatalk. Try using your browser though - TalkBass is now 100% responsive to your phone/tablet screen size ;)

    Please read the TalkBass 2014 FAQ for lots of great info on the new software.

Tubes in my SVT

Discussion in 'Amps [BG]' started by DRafalske, Jan 12, 2014.

  1. DRafalske

    DRafalske

    Joined:
    Nov 6, 2008
    Likes Received:
    0
    Hey guys. Tube question regarding my new-to-me SVT CL. Was setting up for a rehearsal earlier this evening and noticed one of the power tubes not seated all the way. So I removed the screen and made sure all six were seated, and since I was in there and have no knowledge of the service history of the amp, I decided to pull the drivers just to see what was in there. I found a 12AT7 in place of one of the 12AU's. The amp sounds fine, power section biases good, and I've been gigging with it like this for the last few months. I went ahead and played it tonight too. I'm going to replace that 12AT with a 12AU before I use it again, but wondered if any damage may have been done?
  2. beans-on-toast

    beans-on-toast

    Joined:
    Aug 7, 2008
    Likes Received:
    17
    No worries, you won't damage your amp with the 12AT7 in there. Your amp may be a bit dirtier sounding as it is.
  3. DRafalske

    DRafalske

    Joined:
    Nov 6, 2008
    Likes Received:
    0
    Good to know. Thanks!

Share This Page