Warwick blue cab 15 distortion problem

Discussion in 'Amps [BG]' started by badboy1984, Aug 30, 2013.


  1. badboy1984

    badboy1984

    Joined:
    Mar 27, 2007
    Location:
    United Kingdom
    I've bought a second hand warwick blue cab 15 today because i wanted a practice amp, headphone socket and kick back design is good.

    The problem i getting is the bass combo is distorting no matter what bass i play (both active and passive). All EQ is flat and it still distort ........ making it difficult to play.

    So out of interest i plug in a acoustic guitar and it sounded fine even with high volume and crack the bass EQ as well.

    It seems it only produce the distortion on bass guitar ........

    Speaker problem or bass is too hot for this little amp?
  2. B-string

    B-string Supporting Member

    Joined:
    Nov 21, 2008
    Location:
    Lake Havasu City, Az USA
    Have you checked for loose hardware like speaker mounting screws being evenly tight?
  3. badboy1984

    badboy1984

    Joined:
    Mar 27, 2007
    Location:
    United Kingdom
    The input jack was loose which cause volume getting cut but after tighten it is fix. But the tone is complete distort even with low volume and all bass is cut.

    Will tight screw can cause these type of problem?
  4. B-string

    B-string Supporting Member

    Joined:
    Nov 21, 2008
    Location:
    Lake Havasu City, Az USA
    Bass guitar rattles things MUCH harder than a guitar can.

    It is possible the speaker is bad, but try the free things first?
  5. badboy1984

    badboy1984

    Joined:
    Mar 27, 2007
    Location:
    United Kingdom
    I've tighten everything I can possible seeing. Possible bad speaker, but not worth replacing I guess ........

Share This Page