Dismiss Notice

Welcome to TalkBass.com!

Register your free account to unlock features including:

  • Post messages or start new discussions
  • Send private messages to other members
  • Upload images and video to our gallery
  • Enter free giveaways
  • Get rid of this notice, and much more :)

Warwick Fortress One Pot issue

Discussion in 'Pickups & Electronics [BG]' started by Finneus, Feb 18, 2013.


  1. Finneus

    Finneus

    Aug 20, 2007
    Oswego, IL
    I've got a Warwick Fortress One that has an issue with the volume pot. When in the down position, it sticks a little bit at "10", but then will continue to spin around and around.

    I've taken the bass to a tech to have it repaired, but the parts are propreitary to Warwick. He is being told that they will not sell just the pot, that I would have to purchase the entire electronic setup (not sure exactly what this means, other than it costs $150). The pot itself should be a $10 part, so needless to say I do not want to go this route, neither does my tech, who is also very frustrated.

    Wondering if anyone else has run across this with Warwick, or if anyone knows where else I might be able to find this part.
     
  2. WarwickOfficial

    WarwickOfficial

    May 15, 2012
    Disclosures:
    Warwick & Framus Social Media
    Simply give the Warwick Custom Shop in NY a call, and they should be able to help you out. Dan at 212-777-6990 or by email: d.africano@warwick.de Thanks!
     
  3. WarwickOfficial

    WarwickOfficial

    May 15, 2012
    Disclosures:
    Warwick & Framus Social Media
    To add, yes the Fortress One pot is special as it has the PC Board mounted to the pot. I hope this helps, please let me know if you've got any other questions or if you need assistance in any way. Thanks again!
     



Play guitar too? Become a founding member of TalkGuitar.com