1. Welcome to TalkBass 2014! If you're new here, we just went through a major site upgrade. Please post all concerns and bugs to the Forum Usage Issues forum. We will be monitoring that forum. Thank you for all of your feedback.

    The TB Android app is working, you may need to uninstall/reinstall. The iPhone app is now updated and should work after you upgrade. TalkBass is responsive to any screen size, so we recommend using your mobile browser for full functionality.

    Please read the TalkBass 2014 FAQ for lots of great info on the new software.

Washburn xb400 - no output

Discussion in 'Pickups & Electronics [BG]' started by cdactivist, Dec 5, 2013.

  1. cdactivist

    cdactivist

    Joined:
    Feb 1, 2013
    Likes Received:
    0
    Hey guys
    Just bought an early 90s Washburn grover Jackson 4string xb400 on eBay for £80 ($140ish)

    Its a beautiful piece in really good condition apart from there is no output
    - could just be a jack socket as the lead didn't sit quite right but could be the electronics are shot for all I know (I am not skilled or have a meter to test)

    In waiting to hear back from the seller but given the cost, I have offered to keep it for a refunded percentage and I'll take the risk on trying to sort it out

    I can solder etc but here comes the questions... :) ..
    If seller agrees and I keep this, are the electronics worth trying to save?
    If not is the wood/neck good enough to warrant sticking new electronics in ?

    If so, what would you recommend?

    This bass feels really well crafted - better then a lot I've checked out (I am fairly much a newbie btw)

    Thanks in advance
    Adrian
  2. Larry Mal

    Larry Mal

    Joined:
    Nov 1, 2011
    Likes Received:
    0
    I'm interested in this questions also. No advice yet. Good luck!

Share This Page