...yet another EMG problem

Discussion in 'Pickups & Electronics [BG]' started by Pills Are Yummy, Feb 23, 2013.


  1. Pills Are Yummy

    Pills Are Yummy

    Joined:
    Dec 6, 2012
    Location:
    Santa Rosa, California
    I'm running a Dean Razorback with EMG 35DC's with b112rh volume, b112rd volume, and the BTC control. There is almost absolute zero signal coming through, and what little i can hear through my amp is heavily distorted (almost like a built In overdrive:eyebrow:)

    I checked out the wiring diagrams, made sure everything was done right, still nothin. Please help? :bag:
  2. hrbassji

    hrbassji Supporting Member

    Joined:
    Jan 20, 2012
    Location:
    Chicago, IL
    Please don't be insulted, but the first thing to check may be the battery
  3. Pills Are Yummy

    Pills Are Yummy

    Joined:
    Dec 6, 2012
    Location:
    Santa Rosa, California
    I feel stupid.

    The EMG website shows the "proper" wiring into the jack, and I get the distorted sound. So I just reverse the wires and its gone. But the tone is still way too bright
  4. testing1two

    testing1two Gold Supporting Member

    Joined:
    Feb 25, 2009
    Location:
    Southern California
    How's your pickup height? EMGs like to be very close to the strings.
  5. Register to disable this ad
  6. levis76

    levis76 Supporting Member

    Joined:
    Apr 14, 2007
    Location:
    48313
    DCs are meant to be bright. If you want a mellower tone, try a set of CS or EQ out the treble.

Share This Page