1. Welcome to TalkBass 2014! If you're new here, we just went through a major site upgrade. Please post all concerns and bugs to the Forum Usage Issues forum. We will be monitoring that forum. Thank you for all of your feedback.

    The TB Android app is working, you may need to uninstall/reinstall. The iPhone app is now updated and should work after you upgrade. TalkBass is responsive to any screen size, so we recommend using your mobile browser for full functionality.

    Please read the TalkBass 2014 FAQ for lots of great info on the new software.

Yorkville XM200

Discussion in 'Amps [BG]' started by s4001, Dec 4, 2013.

  1. s4001

    s4001

    Joined:
    Feb 2, 2009
    Likes Received:
    0
    After many years of service, my XM200 has issues. it seems the power supply inside may have come loose. Problem is, I can't find a way to open it. It looks like the amp may slide out (minus a couple screws,) but it won't budge.

    Anyone have experience with these?
  2. MuthaFunk

    MuthaFunk

    Joined:
    May 8, 2007
    Likes Received:
    0
    The strap handle screws may thread into the chassis... You can slide the plastic covers off to reveal the handle screws. Other than that, I'd think it'd be self explanatory to disassemble that combo. Just remove all the screws. :)

    Brute force and ignorance can overcome anything.:smug:
  3. s4001

    s4001

    Joined:
    Feb 2, 2009
    Likes Received:
    0
    Hah. I'm almost to the brute force phase. The worst that could happen is that it won't work. ;)

Share This Page