1001RB-II issues

Discussion in 'Amps and Cabs [BG]' started by needmoney, Aug 8, 2005.

  1. had issues/problems etc.?

    3 vote(s)
  2. run perfectly fine the whole time you've had it?

    21 vote(s)
  1. I'm about to take the plunge and get a brand new 1001RB-II. I'm wondering how many people have had reliability issues or faults/problems with their 1001RB-II's, or if they've never had any problems. I figured a poll was the best way to do it.

    So whose had issues and who hasn't. Also if you could explain what the problem was (if any), that would be awesome :hyper:

  2. Hey Again... :)

    I had an older 400 RB III, which had a small problem (brought secondhand) with the effect loop bypass- you needed to run a patch lead between the send and return jacks for it to put out sound. It was probably just a cold solder joint, could have been fixxed but I was too lazy :p

    Other than that the amp was perfect, the newer RB's have more juice, and sound better, I dare say realibility went up too- They are pretty solid amps, and I cant see you having much trouble withit.
  3. Tash


    Feb 13, 2005
    Bel Air Maryland
    You should probably make a distinction between the RB and RB-II amps. My impression is that they are worlds apart regarding reliability.
  4. I did, in the title and the post itself.
  5. ras1983


    Dec 28, 2004
    Sydney, Australia
    I will be getting soon myself (infact its on lay-by). So i did a lot of research on previous threads here on TB. I found the following:

    1. Generally, there weren't too many problems with the RB-II. The RB-I had more problems according to TB'ers. I stress TOO many problems because there were some. i would recommend a search of 1001RBII.

    2. Daniel Elliot (if that's his name) of GK posted that at the thime they had only had 3 RB-II's with known defects, and they were minor defects.

    3. TB'ers, generally speaking, were quite happy with their 1001RB-II's.
  6. Doug Parent

    Doug Parent Supporting Member

    May 31, 2004
    San Diego, Ca.
    Dealer Nordstrand Pickups.
    It's been a workhorse.
  7. Quadzilla

    Quadzilla Supporting Member

    If you check Harmony Central, you will see that a lot of the early RBII's had issues with them frying. From what we are told, GK got that issue under control and if you are buying a new one today, you should be ok.
  8. mine works like a charm. although i've only had mine for 3 months or so.
  9. Aram


    Feb 2, 2003
    New York, NY
    I've had mine about a year -- I play on it every night, and have gigged with it many times and it has never had any problem.
  10. NJL


    Apr 12, 2002
    San Antonio
    define "a lot"


  11. cheezewiz


    Mar 27, 2002
    I used an RB1001II for a year, gigging quite a bit, with absolutely NO problems.
  12. Squidfinger

    Squidfinger I wish I could sing like Rick Danko.

    Jan 7, 2004
    Shreveport LA
    I've had my 1001RB-II for a little over a year now and the only problem I've had is a scratchy pot. I would take the cover off and clean it but that would void my warranty. I'm taking it to the music store today hoping for a trade. It's just not my tone.
  13. millions?
  14. The problems that happened with the 1001RB were fixed when the 1001RB-II was released.

    Ive had two on the road, with seperate bands on average of 150 dates a year, and havent had one issue. One guy even dropped my rack about 5 feet and that 1001RB-II still works just fine.
  15. Wes Whitmore

    Wes Whitmore Supporting Member

    Mar 10, 2003
    Columbus, OH
    Mine has been rock solid.
  16. +1
  17. Bump. I'm sure there's more GK owners than this. Good results thus far though. Very gratifying, thanks people!
  18. I had a GK1001RBII for a short amount of time - very impresive!!
    Lots of headroom. I had it too short of time to comment on the reliability. One thing I noticed is GK seem to be really hell bent on building a quality product if the posts by Dan Elliot are any thing to go by.
  19. Vanni


    Sep 15, 2003
    Milan, Italy