1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

1999 SWR bass 350 fan not turning on/ triad cab

Discussion in 'Amps and Cabs [BG]' started by IronSean7, Mar 17, 2009.


  1. IronSean7

    IronSean7

    Mar 7, 2009
    i bought a bass 350 (chrome) with the fan switch, and the fan does not turn on,, i got a great deal on the amp, it sounds unbelievable, but the fan is not turning on with the switch in the on position, my father has the older basic version with the Auto fan that works great, i was just wondering if anyone else has ever seen this issue before or if the fan will turn on by itself if it gets hot, i havnt really heated her up yet,, ill end up taking it apart and testLIGHTing it if i cant find any info on this,, thank you guys. Also if anyone has ever run the Triad cab with this amp, i would like your imput,, ive heard its a great combination with a well rounded sound,, either way, im buying one,, but i like the imput, thanks again
     
  2. lazyone2

    lazyone2

    Jul 27, 2006
    new jersey shore
    I have the 350x. There is an on/off switch in the back but on is auto. Off is off. The fan only comes on if the amp gets hot.
     
  3. the engine

    the engine Guest

    I have an older SurpRedhead. The fan went out pretty early. lazyone2 is probably right. Wait until it gets warm and see what happens. But the fan is no big deal to replace. It just plugs in on mine. Couple of screws and you're back in business. Good luck!
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.