1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

800 rb dead once again

Discussion in 'Amps and Cabs [BG]' started by test dude, Oct 11, 2010.


  1. test dude

    test dude

    Nov 13, 2006
    Long Island NY
    It's over : ( The story began when I bought the GK 800rb off craigslist. Later to find out it was my fathers friends son. Took it home, used if for a few months (maybe a year). Then the smell of smoke which led to the heads demise. My father took it to someone he know's with an electric shop and they had fixed it. knew it worked now, but put it under the bed and hadnt used it for awhile. Now yesterday at a tryout, the thing must have overheated maybe the second song in. It just stopped dead in its tracks but the light was still on.(goodthing i had my backup head) Plugged in the GK today and all it done is make a constant humming noise. Any clue on what this is? Though Its not my priority anymore cause Im sick of it.
     
  2. PhatBasstard

    PhatBasstard Spector Dissector Supporting Member

    Feb 3, 2002
    Las Vegas, NV.
    I had one about 20 years ago.
    Went down 4 times in a 5 year period. :eyebrow:

    Back then these were super popular. I knew many other players with similar issues.
     
  3. BassmanPaul

    BassmanPaul Inactive

    The 800RBs power section is a simple reliable unit. If you use it within its ratings they last a long time. On the low amp you have a 4Ω limit but on the high amp it's an 8Ω limit. If you go below those limits the amp will fail.
     
  4. Yeah man sounds to me like you probably went below the minimum load...
     
  5. PhatBasstard

    PhatBasstard Spector Dissector Supporting Member

    Feb 3, 2002
    Las Vegas, NV.
    Nope and Nope. When I got it I was running a single 8 ohm 15 cab. Later was running one or two Hartke 410XL's (both 8 ohm BTW).

    The 4 repairs were spread over 3 different shops (I was on the road 95% of the time back then). Each shop gave me the same reason for the failure: Bad solder points".

    This wasn't the only piece of GK gear to give me problems over the years.

    Search this site. There are plenty of threads dedicated to GK's QC issues.
     
  6. Had the same exact thing happen on a brand new Ampeg B-100R once (Loud Technologies).

    Sorry it happened to you.
    You might want to steer clear of GK and Ampeg. Pretty sure I will at least for awhile until their reputations improve. Just my 2 cents.
     
  7. jackcheez

    jackcheez

    Sep 13, 2010
    Long Beach, CA
  8. PhatBasstard

    PhatBasstard Spector Dissector Supporting Member

    Feb 3, 2002
    Las Vegas, NV.
  9. Primary

    Primary TB Assistant

    Here are some related products that TB members are talking about. Clicking on a product will take you to TB’s partner, Primary, where you can find links to TB discussions about these products.

     
    Mar 1, 2021

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.