1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

A Severe Lack of Bottom End...Help Please?

Discussion in 'Pickups & Electronics [BG]' started by Bo_H, Jul 29, 2007.


  1. Bo_H

    Bo_H

    Jul 2, 2004
    Sorry if this is a repeat, I couldn't find a suitable answer even with a search.

    Here are the specs on my bass:

    Spector Legend 5
    EMGHz pickups--single @ neck--humbucker @ bridge.

    Passive wiring with 250k pots (v/v/t) and a .050mf cap.​

    That's about all the info I know to give you. I'll be glad to answer any more questions for you if I've missed some critical information.

    I'd like some input on anything I can add to the circuit or change around to resolve the issue. I dig the feel and playability of the bass, but have yet to find a tone that satisfies.

    Perhaps I have something wired wrong? I've looked back over the diagram (actually several) to see what could be wrong. If you have experienced this problem or know what the culprit is, I am all ears (or eyes).

    EDIT: I'd like to keep the bass passive as well.

    Thanks!

    Bo
     
  2. Do you get more bottom end when its only one pickup on? And its weakest when both are on?

    If thats the case, your pickups could be out of phase with each other.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.