1. Please take 30 seconds to register your free account to remove most ads, post topics, make friends, earn reward points at our store, and more!  

Acoustic 360 preamp problem

Discussion in 'Amps and Cabs [BG]' started by washapdude90, May 4, 2010.


  1. I own an Acoustic 360 preamp and I am taking the output and putting it through my Sunn head for a power amp. When I turn the power on, I am hearing a single tone and it is not the electronic tuner. I took it apart and there are no loose wires or issues with soldering. The only problem I saw was a very messed up vari-amp knob. It is all corroded but still in place pretty good. Any advice?

    :help:
     
  2. bongomania

    bongomania Commercial User

    Oct 17, 2005
    PDX, OR
    owner, OVNIFX and OVNILabs
    Well, a very corroded pot is very bad news. Replace that. Aside from that, do you have a DMM for testing ground continuity?
     
  3. I have one in the electronics class I'm in, so i can check out where it is loosing power, I would just like to know where the random tone is comming from, because it is constant and I have no clue how to get rid of it. The variamp switch changes the tone of the pitch but never gets rid of it even if I have the variamp turned off. I will try and get an audio clip up tomorrow if I have a chance.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.